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Information in this document is subject to change without notice and does not represent a 

commitment on the part of Technical Difference, Inc. The software product described in this 

document is furnished under a license agreement or nondisclosure agreement. The software 

and this documentation may be used or copied only in accordance with the terms of that 

agreement. 

All names of companies, products, street addresses, and persons are part of a completely 

fictitious scenario and are designed solely to document the use of People-Trak. Similarities to 

real companies, products, addresses, or persons are purely coincidental. 

People-Trak is an extensively customizable HR software product. Screen and report samples 

rendered in this document reflect the default version of People-Trak. These samples may or 

may not match the screens and reports within your product if customization has been 

performed. 
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User Types 

The user type is assigned to a People-Trak user in User Setup and determines what People-

Trak desktop and functionality is available to that user.  

People-Trak supports the following user types: 

 HR - HR User  

 Employee - Employee Self-Service User (ESS) 

 Manager - Manager Self-Service User (MSS) 

 Ex-Employee- Ex Employee Self Service User (Ex-e) 

 Applicant –Career Center User (CC) 

 Visitor - Visitor User 

 

The HR user type is the only one available in the base People-Trak Essential HR product. The 

Employee, Manager, and Ex-Employee user types are added when Self Service Employee/ 

Manager has been implemented. The Applicant and Visitors are added with the 

implementation of Self Service Recruiting. 

Starting People-Trak 

People-Trak can be started by selecting the People-Trak icon from your desktop or from the 

Start menu. The People-Trak Login screen is displayed. 

Entering Your User ID/Password 
Access to People-Trak is granted using a User ID/Password combination. The User ID and 

Password is assigned in different ways based on the user type. The HR user type is assigned 

using User Setup.  

To access People-Trak, enter your user ID and password into the respective fields on the 

People-Trak Login screen. Note that the actual password characters are not displayed. When 

a correct combination is entered, access is granted to People-Trak and the next screen is 

displayed. If an incorrect combination is entered, you will receive an error message and you 

must try again. If you enter your password incorrectly three times, People-Trak closes and 

you will have to start over by reopening People-Trak. If you forget your password, you have 

the option of clicking the “Forgot your password” link. You will be asked your forgotten 

password question and you must give the correct answer to have your password emailed to 

you. You define that question and answer in User Setup on the Login tab. 

Based on settings in Enterprise Setup, you will be periodically required to change your 

password. The Change Password screen will display when it is time for you to change your 

password: 

You would then enter the required information and click Submit to change your password.  If 

you do not submit a change, you will have a number of grace logins (set in Enterprise Setup) 

before you are shut out of People-Trak completely. If that happens, you must contact the HR 

Administrator to get your login reactivated. 
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People-Trak Organizer Desktop 

When access has been granted to People-Trak, the People-Trak Organizer desktop is 

displayed. The People-Trak Organizer desktop is highly customizable by company and by 

user. This desktop is only available to HR users and is the default desktop within Essential 

HR. From this desktop, it is possible to switch between modules and run processes in a 

variety of ways. The Tasks pane allows the user to quickly access frequently-used tasks. The 

People-Trak News pane includes links to the latest information provided by People-Trak.  

Modules 

A module is a self-contained component of a software program. People-Trak has up to twelve 

different modules that make up its HR Information System. They are: 

 Personnel Management   

 Safety Management  

 COBRA Administration  

 Benefit Administration 

 Training Course (optional) 

 Training Administration (optional) 

 Position Control (optional) 

 Requisition Tracking (optional) 

 Applicant Management (optional) 

 Contact Management  

 Generic Module (optional) 

 Document Management (optional) 

 

The Position Control, Requisition Tracking and Applicant Management modules are added as 

part of the Position Control option. The Training Course and Training Administration 

modules are added as a part of the Training Administration option. The Generic and 

Document Management modules are added as part of the Strategic Toolkit option.  

 

Selecting a Module 
In the Organizer desktop, you can easily select a module by clicking on the appropriate 

module name in the Modules pane. You can only select a module to which you have been 

given access, which is controlled in the Security Setup process. When you select a module, 

the following changes take place: 

 The Main Menu Bar includes the options for the selected module. 

 The Shortcut Bar includes options for the selected module.  

 

Workflows 

A workflow is a collection of one or more screens. People-Trak includes a standard workflow 

for each module that is used to collect the information required. The name of the standard 

workflow for a module is “Standard - ” followed by the record maintained by the module. For 

example, the Personnel Management module maintains the Employee record, so the standard 

workflow is “Standard - Employee”.  

When you create a new record or open an existing one, the default workflow for that module 

is opened. The workflow screen replaces the processing area of the desktop.  
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You can change the standard workflow for a module per user using User Setup. You can 

remove screens and change the order of the screens in the standard workflow. 

Working with Records 

In the Organizer desktop, once you have selected a module, you can work with the records 

associated with that module, based on your access as determined in Security Setup. For 

example, if you have selected the Personnel Management module, you can then create, open, 

delete, transfer or copy an employee record. If you have selected Safety Management, you 

can create, open, delete, transfer or copy an incident record. 

Working with Companies 

People-Trak is a multi-company product. By default, the product comes with two pre-defined 

companies: ACTIVE and ARCHIVE. You can use these two companies in any way that you 

wish, but they are actually designed to contain your active company information and your 

archived company information. You can create and utilize other companies as well. 

Regardless of how many companies you actually have, the operating conventions for working 

with these companies remain the same. These are described below. 

Changing the Default Company 
Each user is assigned a “default” company. This is the company you are attached to when you 

first log in. The Default Company is initially set with the User Setup process when the user is 

created. You can change the default company at any time to any other company to which you 

have access.  

Note: If you are assigned to a default company and are then denied access to that company at 

a later time, you cannot attach to that company at login.  

Controlling Access to Companies 
Access to the standard two companies or to any of the companies that have been defined is 

controlled with the Security Setup option on the Setup menu.  

Identifying the Current Company 
You can identify the company to which you are currently attached by looking at the company 

name in the header of the desktop, if the company header is being used. 

Logging Off  

In the Organizer desktop, you can simply click the Logoff shortcut or select the Logoff option 

on the File menu. Either way, you will be logged off as the current user and the People-Trak 

Login screen will appear. You then have the option of entering a User ID/Password to log 

back into People-Trak or clicking Cancel to exit People-Trak. 
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Organizer Desktop 

 
 

The Organizer desktop allows the user to switch between modules and run processes in a 

variety of ways. The Organizer desktop is only available to HR users. The following is a 

sample of an Organizer desktop with its components labeled.   

 

  

The following sections describe each component of the Organizer desktop. 

People-Trak Bar  

The People-Trak Bar is displayed at the very top of the Organizer desktop. It contains the 

People-Trak name on the left, and Minimize and Close buttons on the right. 

 

Header  

The Header is located below the People-Trak Bar. This area will include either the enterprise 

or company name and image as specified in Desktop Setup.  

Desktop Bar 

The Desktop Bar is located below the Header. It includes the name of the current desktop. 

 

People-Trak Bar 

Main Menu Bar 

Categories Pane 

Tasks Pane 

Status Bar 

Modules Pane 

People-Trak News Pane 

Header 

Shortcut Bar 

Desktop Bar 
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Main Menu Bar 

The Main Menu Bar is displayed below the Desktop Bar. It contains a phrase for each of the 

People-Trak menus. When the mouse is clicked on one of these phrases, the corresponding 

menu is displayed. Each of the menus listed on the Main Menu Bar is described in detail 

below.  

File Menu 
The File menu contains options for creating, changing, and deleting records (employees, 

applicants, COBRA recipients, etc.) and performing other tasks related to records stored 

within the current module.  

When you see the Record placeholder in the descriptions below, this refers to the primary 

item being tracked by the module. On the actual menus, the Record placeholder will be 

replaced with the appropriate name. For example, for employee records tracked in the 

Personnel Management module, the menu phrases will be “New Employee”, “Open 

Employee”, etc. A similar, appropriate phrase applies to each module. 

 New Record  

 Open Record  

 Select Company  

  Logoff User  

 

Documents Menu 
The Documents menu contains a list of document types.  

When you select a document type option, the Explorer is displayed for that type. You can 

then create, update or run documents.  

Templates Menu 
The Templates menu contains a list of template types.  

When you select a template type option, the appropriate template screen is displayed. You 

can then create, update or edit templates.  

Workflows Menu 
If you have workflows defined for the current module that are to be shown on the menu, the 

Workflows menu is displayed on the Main Menu Bar. The Workflows menu contains 

workflows that have the Show on Menu check box selected.  

Activities Menu 
The Activities menu is displayed on the Main Menu Bar and contains the activities available 

in the current module.  

All modules have a standard Manager activity for their respective records. For example, in 

the Personnel Management module, there is an Employee Manager activity, in the Safety 

Management module, there is an Incident Manager, and so on. These activities allow you to 

update records in a module using a more process-oriented approach. These activities also 

provide non-HR users (such as managers when Self Service Employee/Manager is 

implemented) a more user-friendly interface for updating records. In Module Setup, you 

define the lookup and result fields to use for the record Manager activity as well as specify 

the default source for create. 
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Processing Menu 
If Processing options exist for the current module, the Processing menu is displayed on the 

Main Menu Bar and contains those options.  

Tools Menu 
The Tools menu in the base People-Trak Essential HR product contains options for 

maintaining tables, changing passwords, setting alarms, as well as using productivity tools 

such as the alert triggers, schedule triggers, and the inbox. Menu options are lsited below: 

 Inbox  

 Maintain Tables  

 Set Alarm  

  Change Password  

 Alert Triggers  

 Schedule Triggers  

 

Note: Only users with Administrator access (Administrator check box selected in Security 

Setup) have access to the complete Tools menu. Non-Administrator users only have access to 

the Inbox, Maintain Tables, Set Alarm and Change Password options on the Tools menu. 

Administration Menu 
This menu contains options for performing a wide variety of administration tasks. Menu 

options are lsited below: 

 Screen/Field Customization  

 System Templates  

 Email Attachments 

  Email Definitions 

 Audit Reports 

 Audit/Transaction History 

 Database Manager 

 Import 

 Backup 

 Restore 

 Utilities 

 

Note: Only users with Administrator access (Administrator check box selected in Security 

Setup) have access to the Administration menu. Non-Administrator users do not have this 

menu on the Main Menu Bar.  

Setup Menu 
This menu contains options for performing setup tasks. Menu options are lsited below: 

 Enterprise Setup  

 Desktop Setup  

 Company Setup   

 Module Setup  

 User Setup  

 Security Setup  

 Security Setup - Module  

 Table Setup  

 Audit Setup  
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Note: Only users with Administrator access (Administrator check box selected in Security 

Setup) have access to the Setup menu. Non-Administrator users do not have this menu on the 

Main Menu Bar. 

Help Menu  
This menu contains options for the Help features within People-Trak. Menu options are lsited 

below: 

 Help Topics  

 Support Online  

 Help About  

Shortcut Bar 

The first column on the left-hand side of the Organizer desktop, called the Shortcut Bar, 

provides shortcut icons, much like Microsoft Outlook. These icons are used to more easily 

access important features of People-Trak without having to open the File menu.  

Modules Pane 

The Modules pane includes the list of the People-Trak modules that have been activated in 

Desktop Setup and to which you have been given access in Security Setup. To select a 

module, simply click on the module name.  

Categories Pane 

The Categories pane includes a list of categories that have been defined for the current 

module. The treeview hierarchy allows you to drill down into Activities, Processing, 

Documents, Tables and Workflows that exist within each category. In their respective 

processes, you can assign Documents and Workflows to an existing Category, which will 

then cause them to show up in this Categories pane under that category. 

To open up a category, click the + sign to the left of the category. The + sign will turn to a – 

sign for that category, signifying that the category is now open. The subcategories (Activities, 

Processing, etc.) that have items in them will now be shown. As with the main category, click 

the + sign to open that category. The + sign will turn into a – sign for that subcategory, 

signifying that the subcategory is now open. The items in that subcategory will now be 

shown. To select an item, click on it. To close a category or subcategory, click the – sign to 

the left of that category/subcategory. 

Tasks Pane 

The Tasks pane includes a listing of frequently-used tasks that have been specified for the 

user within the Desktop Tasks screen found on the Preferences tab in User Setup. To select a 

task, click on it. The module will automatically switch based on the task selected, and the task 

will be executed. When the task is completed, you will be returned to the module you were in 

when you selected the task. The Tasks pane is a convenient way of accessing tasks that you 

use often. You have the option of grouping these tasks so you can open and close groups like 

you do for categories in the Categories pane. If you would like to see the extended 

descriptions for the task, hover over the task and a tool tip with the description will be 

displayed. The Tasks pane also includes a bar at the bottom with links to three standard 

activities: Help, Inbox and Logoff. 
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People-Trak News Pane 

The People-Trak News pane includes links to the latest information provided by People-Trak. 

The links in this area will be updated nightly when running the NightRun process. You can 

view video tips, customer notifications and other important information to keep you up-to-

date. There will be up to ten links as well as an Archive link, which accesses an index of past 

news items. 

Status Bar 

The Status Bar is displayed at the very bottom of the Organizer desktop. It contains panels for 

messages, a progress monitor, the People-Trak version, the database type, the system date, 

the user type and the record counter. The messages and progress monitor panels are blank 

until there is a message or processing in progress. The following example shows just the last 

five panels. 

 

Note: In order to alert you, the numbers for the Record Counter will change colors as the 

number of records used approaches the number of records licensed. You will need to contact 

your Support Representative to license more records as needed. 

 

The Workflow Area is the area of the desktop that is used to process workflows. All desktops 

utilize the area below the Header and above the Status Bar for workflow processing.  

A sample desktop with the Standard - Employee workflow open for processing is shown 

below. 

 

Tool Bar 

Navigation Bar 

Primary Screen 

Area 

 

Category 

Bar 

Menu Bar 

Title Bar 
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Notes 
 

  



  

 

 
Workflow Area 

 
 

Title Bar 

The Title Bar is at the top of the Workflow Area and includes the name of the workflow that 

is currently being processed. The X on the right-hand side of the bar can be used to close the 

workflow (as can the Close Record option). 

Menu Bar 

The Menu Bar is below the Title Bar and above the Tool Bar. It includes the menus described 

below. 

File Menu 
The File menu contains several options for dealing with records as well as for printing the 

screen, viewing documents, sending email and editing the lookup.  

When you see the Record placeholder in the descriptions below, this refers to the primary 

item being tracked by the module. On the actual menus, the Record placeholder will be 

replaced with the appropriate name. For example, for employee records tracked in the 

Personnel Management module, the menu phrases will be “New Employee”, “Open 

Employee”, “Delete Employee”, etc. A similar, appropriate phrase applies to each module.  

 New Record  

 Open Record 

 Save Record 

 Close Record 

 Delete Record 

 Copy Record 

 Transfer Record 

 Print Screen 

 Record Status 

 Send Email 

 Edit Lookup 

 Exit 

 

Edit Menu 
The Edit menu contains several options used for editing fields.  

The options on the Edit menu, as well as the corresponding buttons on the Tool Bar, turn on 

and off as the appropriate features are enabled.  

 Undo  

 Undo All 

 Cut 

 Copy 

 Paste 

 Delete Text 

 Date Stamp 
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 Set Date Stamp  

 Select All 

 Insert Row 

 Delete Row 

 Row Up 

 Row Down 

 

Audit Menu 
The Audit menu contains several options used for viewing edit history, field audit history, as 

well as audit and transaction history.  

 Edit History  

 Field Audit History 

 Audit History 

 Transaction History 

 

Help Menu  
This menu contains options for the Help features within People-Trak. Menu options are lsited 

below: 

 Help Topics  

 Support Online  

 Help About 

Tool Bar 

The Tool Bar is displayed between the Menu Bar and the Navigation and Category Bars. It 

contains buttons to do file, edit and help functions. 

Buttons will be disabled when they are not applicable. For example, the four grid buttons 

above are disabled because the current field is not in a grid. The Tool Bar above is from a 

primary screen. A sub screen would not have the New, Open or Close buttons on its Tool Bar 

since those are only applicable on a primary screen. Toolbar buttons are lsited below: 

Note: Each People-Trak process also has a Tool Bar. The buttons are similar to those 

described below. Some buttons may not be available depending on the process. For example, 

the User Setup process has a Tool Bar identical to the one above, except the Open button is 

not applicable because a list box is used to select users to update. 

When you see the Record placeholder in the descriptions below, this refers to the primary 

item being tracked by the module. On the tooltips, the Record placeholder will be replaced 

with the appropriate name. For example, for employee records tracked in a personnel module 

the tooltip phrases will be “New Employee”, “Open Employee”, “Delete Employee”, etc. A 

similar, appropriate phrase applies to each module. 

 New Record  

 Open Record 

 Save Record 

 Close Record 

 Print Screen   

 Cut 

 Copy 

 Paste 
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 Date Stamp 

 Undo Current Field 

 Insert Row 

 Delete Row 

 Row Up 

 Row Down 

 Show Field Help 

 Show Screen Help 

Navigation Bar 

The Navigation Bar is displayed after the Tool Bar and before the main body of the screen. 

The Navigation Bar contains features used to navigate among the records that have been 

selected for editing.  

 

Record Dropdown  
Performs three functions. It displays the group of records established at lookup. It also 

displays the currently selected record. Lastly, it allows you to select from any of the records 

in the group. The group is initially filled using the Lookup option and can be modified using 

the Edit Lookup feature on the File menu. 

First Record  
Selects the first record in the group of records listed in the Record dropdown. 

Previous Record  
Selects the previous record in the group of records listed in the Record dropdown. If the first 

record is the current record, the last record becomes the current record. 

Record Counter  
Indicates the position of the current record relative to the group of records listed in the 

Record dropdown. For example, the phrase “4 of 30” indicates that the fourth record in a 

group of 30 is currently displayed. This message is updated whenever the current record is 

changed using the Record dropdown itself or when any of the First, Previous, Next, or Last 

buttons are used. 

Next Record  
Selects the next record in the group of records listed in the Record dropdown. If the last 

record is the current record, the first record becomes the current record. 

Last Record  
Selects the last record in the group of records listed in the Record dropdown. 

Category Bar 

The Category Bar is displayed after the Tool Bar and before the main body of the screen. The 

Category Bar is used to navigate among screens and category buttons available in the current 

module. The Screens dropdown performs three functions. It contains a list of the screens that 

you can access. It also displays the current screen name. Additionally, it allows you to select 

from any of the screens you can access. The list of screens in the dropdown is determined by 

the screens and categories to which you have been given access in Security Setup - Module. 
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If you do not have access to a screen, it will not be listed in your Screen dropdown.  
 

 

Previous  

Selects the previous screen in the dropdown. If the first screen is the current screen, the last 

screen becomes the current screen and is displayed. The keyboard equivalent for the previous 

screen function is the PAGE UP key. 

Next  
Selects the next screen in the dropdown. If the last screen is the current screen, the first screen 

becomes the current screen and is displayed. The keyboard equivalent for the next screen 

function is the PAGE DOWN key. 

Category Documents  
Allows you to select the document and record type (Current Record, Current Group or Use 

Query) for which you want the document to run. Only documents assigned to the current 

category will be available. 

Category Tables  

Allows you to view and edit tables that have been assigned to the current category. Tables 

that are non editable are viewable as display only. 

Category Notes  
Allows you to view all notes that have been assigned to the current category. This button is 

only available if the Notes check box is selected for the user in Security Setup. 

Category Help  
Allows you to view help for all screens, tables, documents, templates, derived fields, 

processing and workflows that have been assigned to the current category. 

Primary Screen Area 

The actual body of the Workflow Area is the Primary Screen Area. Each workflow can have 

one or more primary screens, which can be selected using the Screen dropdown. The 

following is a sample of the Personal screen in the Standard-Employee workflow of the 

Personnel Management module 

Each primary screen can have sub screens, which are accessible via buttons. In the screen 

above, the Emergency through ID buttons on the right give you access to those sub screens 

when you click them.You can expect to see a very standard interface no matter what module 

you are currently in. 

 

 



  

 

 
Operating Conventions 

 
 

Data Validation 

People-Trak uses two types of data validation: entry and post-entry.  

Entry Validation 
Entry validation occurs during the actual keying or “entry” of the field and is designed to 

prevent invalid characters from being entered into a field. Entry validation is limited to date 

fields, numeric fields, and time fields. If you are positioned to a date field and press an 

invalid character, the character will be ignored because the field knows what characters are 

valid. If you are positioned to a numeric field or a time field, the same is true. The field will 

limit characters to those that are valid. 

Post-Entry Validation 
People-Trak also uses “post-entry” validation. This occurs when you press the ENTER key or 

the TAB key to move the cursor to another field or when you use another key to change the 

cursor location. It also occurs when you use the mouse to move the cursor. During post-entry 

validation, the contents of the field are compared against pre-defined attributes of the field. If 

the data entered does not match the attributes of the field, the entry is rejected and the cursor 

remains at the field you had just requested to leave. 

 

Post-entry validation is required because not all attributes of a field can be checked during 

entry and because of the cut, copy, and paste features. With the cut, copy, and paste features, 

you can take the contents of one field and move them to another. The data that has been 

moved is not validated until you attempt to leave the field. If you have pasted character data 

into a numeric field, you will not be able to leave the field until you have corrected or erased 

the entry. 

Required Fields 

Default Required Fields 
By default, there is a single required field in each module. That field is the unique ID 

(employee ID, applicant ID, etc.) that identifies the record within the company. You cannot 

save a record without having specified a unique ID. If you attempt to save a new record 

without an ID, you will receive a message and you will not be able to save the record. If you 

attempt to change an existing ID to one that is in use elsewhere within the company, you will 

receive a message and the ID you have specified will be rejected. 

If you have chosen to use the Auto-Numbering feature, the IDs that are generated will always 

be unique because they are checked before they are assigned. 

User Defined Required Fields 
People-Trak also allows you to make any field a required field. This is a very powerful 

feature that works as follows. If you position to a required field, you cannot leave that field 

unless you have specified a non-blank value. If you position to the field inadvertently and 

really do not wish to specify a value, you will not be able to leave the field until you provide 

some type of entry. In some instances, the only way you will be able to continue processing is 

to enter a temporary value. 



Workbook 

 

16     Introduction to People-Trak 

If you have a required field on a screen and do not enter a value in that field, you will not be 

able to leave the screen (by any means) until a value is entered. Even if you do not position 

directly to that field, you will not be able to continue processing until that field is given a 

non-blank value. If you have a dozen required fields on a screen, you will not be able to leave 

the screen until a non-blank value has been specified for each and every field. 

Note: This feature is a very attractive feature, but it is very powerful. If you really do not 

intend for a feature to be entirely required, do not use this feature or it will be very, very 

frustrating.  

Formatting 

People-Trak uses three types of data formatting: pre-entry, entry and post-entry. Some fields 

have their format based on the PC’s regional settings or the company settings. 

Pre-Entry Formatting 
People-Trak stores all data in the database in a non-formatted way. Pre-entry formatting 

refers to the formatting that occurs when the data is moved from the database into the field. 

Dates, times, numeric values, telephone numbers and social security numbers are all 

translated from their raw storage format into the formats you have specified in the PC’s 

regional settings or in your company settings. 

Entry Formatting 
Entry formatting refers to the formatting that occurs when a field is entered. This type of 

formatting is limited to date fields, which are difficult to key because of the date separator. If 

you have selected Auto-Delimit in User Setup, the separator (determined by the PC’s regional 

date format setting) is automatically inserted for you when dates are keyed. So, you can 

simply key the numbers and assume that the field will be formatted correctly.  

Post-Entry Formatting 
Post-entry formatting refers to the formatting that occurs when a field has been completed. 

Numeric fields, telephone numbers, and social security numbers are all formatted after they 

have been entered, even if they have been keyed with separators, commas, or decimals. The 

same is true for dates if you have not selected Auto-Delimit in User Setup; in that case, the 

date is formatted to the PC’s regional 10-character date format after entry. Other types of 

formatting are also performed post-entry.   

People-Trak supports three types of case formatting on alpha-numeric fields: none, proper 

case, and upper case. If you have specified the proper case format for the City field, the field 

will be proper cased when you leave the field. For example, if you enter any of the following: 

san diego, SAN DIEGO, sAN DIEgo, the field will be switched to San Diego. Likewise, if 

you specified the upper case format for the City field and you enter any of the following: san 

diego, San Diego, SAN Diego, the field will be switched to SAN DIEGO when you leave the 

field. 

Cut, Copy, and Paste 

People-Trak uses standard Windows cut, copy, and paste conventions at all data entry fields. 

Cut 
The cut feature is used to cut the highlighted contents of a field. Cut removes the highlighted 

contents and stores the contents in the paste buffer. Cut text can be pasted into any other 

applicable field using the Paste option on the Edit menu, the Paste button on the Tool Bar, or 
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the CTRL + INS or CTRL + V key sequence. The Cut feature is available on the Edit menu, 

as a button on the Tool Bar, and as the CTRL + X key sequence. 

Copy 
The copy feature is used to copy the highlighted contents of a field into the paste buffer. Text 

in the paste buffer can be pasted into any other applicable field using the Paste option on the 

Edit menu, the Paste button on the Tool Bar, or the CTRL + INS or CTRL + V key sequence. 

The Copy option is available on the Edit menu, as a button on the Tool Bar, and as the CTRL 

+ INS or CTRL + C key sequence. 

Paste  
The paste feature is used to paste the contents of the paste buffer into any applicable field. 

The paste buffer is a Windows feature and can contain text that has been pasted from another 

product. For example, if you copy the text of an email message in some unrelated task, that 

text is placed into the same paste buffer that is available within People-Trak. The paste buffer 

is not emptied after a paste action, but can be used over and over again. In fact, the paste 

buffer remains until another item has been cut or copied into the paste buffer or until 

Windows is shut down. The Paste option is available on the Edit menu, as a button on the 

Tool Bar, and as the SHIFT + INS or CTRL + V key sequence. 

Note: The paste feature allows you to paste invalid data into fields that have special 

formatting attributes. For example, if you cut or copy an employee last name into the paste 

buffer, you will be able to paste it into both date fields and numeric fields. These types of 

fields do not allow character style data and would normally disallow data entry of such 

characters. When you attempt to leave a field that contains invalid data, the post-entry 

validation feature will prevent you from leaving the field until you have corrected it. 

Date Stamp 

People-Trak provides a special capability at date fields that allows the rapid insertion of the 

current setting of the date stamp. The date stamp capability simulates the mechanical date 

stamp that has been used for many years to stamp documents and mail. The date stamp is a 

special paste buffer. It is filled with the current date when an editing session begins, but can 

be modified at any time using the Set Date Stamp option on the Edit menu. When the cursor 

is positioned to a date field, use the Date Stamp to instantly insert a date into the field. 

On certain screens that have a wide variety of date fields, the Date Stamp feature may not be 

useful. However, with Batch Processing processes where you will need to enter the same date 

many times, this feature can save a great deal of time. The Date Stamp feature is available on 

the Edit menu, as a button on the Tool Bar, and as the F4 key. 

Exiting a Record or Screen 

In a record or in any screen with the Save capability, the record/screen can be exited in one of 

two ways: using the Exit option on the File menu or clicking the “X” in the upper right-hand 

corner of the Workflow Area or screen. The Exit option automatically saves any changes and 

exits the screen. Clicking the “X” asks you if you want to save when changes are made, saves 

or doesn’t save according to your answer and then exits the screen. On a screen without the 

Save capability, the Exit and “X” both just exit the screen because no save is involved. 

 

Note: When editing a record and exiting a sub screen, you are saving changes to the sub 

screen only. Changes to the record are only saved when saving the record itself. In addition, if 

you have accessed the same sub screen multiple times before saving the record, clicking “X” 
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and saying “No” to the save question only discards the current editing session’s changes to 

that sub screen not all changes to the sub screen. 

Enable Preselect 

People-Trak adheres to an operating convention that differs from the standard Windows 

convention. When the cursor is first positioned to a field, Windows normally pre-selects the 

entire entry. If you press any key, the current entry is wiped out and is replaced with whatever 

you type. In the People-Trak standard, the field is not pre-selected.  

If you prefer to use the Windows standard for entry selection, you can change the setting of 

the Enable Preselect check box on the Preferences tab of User Setup. When the check box is 

selected, the Windows standard applies, and an entry will be pre-selected. When the check 

box is not selected, the People-Trak standard applies, and an entry will not be pre-selected. 

This check box is not selected by default. 

Change the Enable Preselect Setting 
The Enable Preselect setting can be switched at any time. The System Administrator can 

switch modes for any user using the User Setup option on the Setup menu.  

Color Conventions 

People-Trak provides user definable colors for four data edit characteristics: normal data, 

modified data, field mask and pending data.  

Normal Color 
The normal color is the color in which data is displayed when no change has been made to 

the field. The default color for normal data is blue. 

Modified Color 
The modified data color is the color in which data is displayed after a change has been made 

to that field, but before it has been saved. The default color for modified data is red. 

Mask Color 
The field mask is that area that surrounds a field when the cursor is positioned to that field. 

The field mask is visible on both text boxes and grids. The default color for the field mask is 

yellow.  

Note: The mask color is also used as the highlight color on most drop-downs and list boxes. 

Pending Color 
The pending color is the color in which data is displayed after a change has been made to the 

field and saved, but before the change has been approved and posted. The default color for 

pending data is magenta.  

Note: If Self Service options are implemented, a pending color is used.  

Changing Color Preferences  
The four data colors can be modified for any color scheme at any time. An Administrator can 

modify the color preferences for any scheme using the Define Colors button within User 

Setup, the Set Colors button in Desktop Setup, or the Maintain Color Schemes utility.  

The changes take effect immediately. You can confirm this by using the updated color 

scheme (assign that scheme to your user in User Setup) and then using any editing screen. 
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Caution: It is possible to select a combination of colors that will cause data to disappear. For 

example, if you select a dark blue mask with dark blue unmodified data, the data will not be 

visible when the field is highlighted.  

Note: The frame, background and font colors in a color scheme can also be changed using 

this procedure. New color schemes can also be created and then assigned using User Setup.  

Using the Undo Feature 

When Changes are Saved 
People-Trak saves data when you close the record, exit the record, change records, click the 

save icon, or use the Close button in the upper right hand of the screen and choose to save. If 

you decide to abandon changes in process on a given screen, you may do so by using the 

Close button and choosing not to save.  

The Edit History Log 
People-Trak maintains an ongoing edit history while you are editing and before changes are 

saved. Every change is recorded as it is actually made. You can view the log at any time 

using the Edit History option from the Audit menu.  

Undo 
The Undo feature can be used to undo data entry that has been performed on any field. The 

feature is very powerful in that you can selectively undo any change that has not yet been 

saved to the database. Fields that have been changed are displayed in the modified color 

rather than the normal color. When you position the cursor to any modified field, the Undo 

button on the Tool Bar will be activated as will the Undo option on the Edit menu. If you 

click the button or select the option, the prior value of the field will be restored.  

The Undo feature uses the Edit History Log. Thus, it is possible to have multiple changes to 

the same field that can be undone. After using the Undo feature to undo the latest change, the 

Edit History Log is checked to determine if there any other changes to the same field for the 

current record. If there are, the field remains in the modified color and the Undo button and 

option remain active. When the last change has been undone, the color is returned to the 

normal color and the button and option are deactivated. 

Note: The Undo feature undoes changes made to individual fields during an editing session. 

It does not undo changes made in bulk using batch processing, import, table mass update, or 

database manager. It is highly recommended that you perform a quick backup prior to 

performing any type of bulk change.  

Undo All  
If multiple changes have been made during the current edit session on one or more screens, 

including row deletes, you can undo all of those changes at one time using this option. The 

Undo All feature uses the Edit History Log to sequentially back out all of the changes that 

have been recorded in the log. However, any actions taken by triggers cannot be undone. In 

addition, a change to the record ID field cannot be undone because that information is written 

to the database upon leaving the field. 

 

Note: When using any undo features, only changes made since the last save can be undone. 

Working with Grids 
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As described in the vocabulary sections, grids are a special class of data entry component. A 

sample grid is shown below. 

Grids are used to display rows and columns of information. The rows often represent multiple 

occurrences of historical data. For example, a grid can be used to store salary history. There 

are columns for the salary date, hours per week, salary rate, annualized pay, etc., that are 

repeated as rows for each salary history. With a few exceptions, a grid can contain as many 

rows as you can enter. 

Capacity 
As mentioned above, most of the grids in People-Trak can contain as many rows as you 

choose to enter. However, to manage the scroll bar properly and to maximize speed, only 50 

rows can be entered at one time. When you first display a screen that utilizes a grid, the grid 

is populated with 50 blank rows. If you enter 20 rows and leave the screen, but then return, 

you will have room for the original 20 rows plus 50 additional rows. Each time you return to 

the grid, you will have the number of existing rows plus 50. If you need to enter more than 50 

rows into a grid at one time, you can click Save and 50 more blank rows will be added to the 

grid. 

Navigation 
Once the cursor has been positioned within a grid, the following navigation keys apply. 

 TAB or ENTER 

 SHIFT + TAB  

 DOWN ARROW  

 UP ARROW  

 Scroll Bar 

 Mouse Clicks  

 

TAB or ENTER moves to the next field in the current row. If the cursor is at the last field in 

the current row, the cursor moves to the first field on the next row. 

SHIFT + TAB moves to the prior field in the current row. If the cursor is at the first field in 

the current row, the cursor moves to the last field on the prior row. 

DOWN ARROW  moves the cursor to the next row within the same column. 

UP ARROW moves the cursor to the prior row within the same column. 

Scroll Bar scrolls the visible portion of the grid, but does not move the actual cursor. For 

example, if the cursor is on the first row and you scroll the first row out of view, the cursor 

remains on the first row. If you scroll the first back into view, the cursor will be present 

where you left it. 

Mouse Clicks can be used to position the cursor to any editable cell. If you are positioning to 

a cell that contains data, the first click will position to the cell and the second click (within the 

same cell) will position the cursor within the data itself. 

Editing 
A grid actually acts like a report upon which a movable text box is positioned. When the text 

box is positioned over a cell (row and column location), the contents of the cell are put into 

the text box. If you modify the text box, the change is moved back into the cell when you 

leave the cell. Because the movable text box works precisely like the stand-alone text boxes 

used elsewhere, the operating conventions are identical. All keystrokes, undo features, tables, 

and other popup features work the same. 
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Similarly, a check box is positioned over cells that utilize the check box attribute. Once the 

cursor is positioned to the cell, the check box component takes on the current attribute of the 

cell (checked or unchecked). If you toggle the check box and then move on, the cell takes on 

the new status of the check box. 

When working with grids, the mask color feature is tremendously helpful. Both the text box 

cells and the check box cells are more easily identified as having the focus when they are 

highlighted with a light color such as yellow. 

Inserting and Deleting Rows 
Because grids contain rows of information, you can insert and delete rows whenever you 

choose. A blank row can be inserted at any location using the Insert Row feature. This feature 

is activated with the Insert Row button on the Tool Bar, the Insert Row option on the Edit 

menu or Function Key 9. Once the blank row has been inserted, you can complete the 

columns in the row by adding the appropriate information. 

A blank row or previously completed row can be deleted at any time using the Delete Row 

feature. This feature is activated with the Delete Row button on the Tool Bar, the Delete Row 

option on the Edit menu or Function Key 8. Deleting a row discards a number of fields at 

once and should be used with some caution. It is not possible to use the standard Undo 

feature to undo the fields that have been deleted. However, if multiple changes have been 

made during the current edit session, including row deletes, you can undo all of those changes 

at one time using the Undo All option. The Undo All feature uses the Edit History Log to 

sequentially back out all of the changes that have been recorded in the log.  

 

Note: When using any undo features, only changes made since the last save can be undone. 

Field Types 

People-Trak uses the set of standard field types listed below. The operating conventions and 

formatting attributes for these fields are consistent throughout People-Trak.  

 

 Color 

 Currency 

 Date 

 File 

 Font 

 Memo 

 Numeric 

 Object 

 Path 

 Text 

 Time 

 Yes/No 

 

Color 
Color fields are used to capture the color attribute for some particular feature. Color fields do 

not store actual color names, but reflect the color actually selected. To change the color, use 

the color popup to select the new color with the mouse. 

Currency 
Currency fields are used to store positive or negative numbers with or without decimal places. 

Two values determine the actual format of a currency field: the length of the field and the 

number of decimal places. 

###.##  Length = 6, decimal places = 2 

######  Length = 6, decimal places = 0 
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######.##  Length = 9, decimal places = 2 

#####.####  Length = 10, decimal places = 4 

The field length and decimal places for currency fields are user defined and can be modified 

with the Field Customization feature. Thus, if the default ##########.## format of the Pay 

Rate field is not acceptable to you, you can change it to any reasonable length with up to four 

decimal places. 

 

Currency fields differ from numeric fields in that when a document is run, a currency symbol 

appears next to the currency field, but not next to the numeric field. The currency symbol is 

defined in Company Setup. 

Date 
Date fields are also widely used in People-Trak. Date fields are the only fields that have the 

option of using “real-time” formatting. This means that the field is formatted as you enter it. 

People-Trak is shipped with the Auto-Delimit feature turned on in User Setup. Auto Delimit 
is a check box that allows you to specify whether or not you want date delimiters 

automatically entered for you when entering a date. If this check box is selected, only 

numbers can be entered in a date field and the delimiter specified in the PC’s regional date 

format setting is automatically entered in the correct positions. If this check box is not 

selected, numbers and a delimiter of “.”, “/” or “-” can be entered in a date field, and the field 

is formatted to the PC’s regional 10-character date format after it is entered. For example, if 

you type in “3.4.9” and press ENTER, the date will be formatted to 03-04-2009 if the PC’s 

date format is m-d-yyyy, mm-dd-yyyy or some variation of that. 

 

Date fields are also supported by the date popup. It uses a calendar to allow you to pick a date 

using a series of mouse clicks for the month, day, and year. Some date fields are also 

supported by the date variables popup, which allows you to select from a list of date 

variables. 

File 

File fields store the full file name of a file. File fields work just like a text field in that any 

value can be keyed. However, when a file is entered, it is validated to determine if it actually 

exists. You cannot record a file that does exist or cannot be validated. File fields are 

supported by the file popup. 

Font 

A font field is actually composed of three different fields: font name, font style, and font size. 

When a font is specified for a particular feature it requires all three entries to define the font. 

To change or set a font, use the font popup to select the three desired attributes. 

Memo 
Memo fields are text fields that can be over 255 characters. Regular text fields have a 

maximum of 255 characters. In a memo field, you can enter the text in the field itself or use 

the multi-line editor popup to enter more than a single line of text. The maximum size of a 

memo field is 2 GB of data. 

Numeric 
Numeric fields are used to store positive or negative numbers with or without decimal places. 

Two values determine the actual format of a numeric field: the length of the field and the 

number of decimals. 
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###.##  Length = 6, decimal places = 2 

######  Length = 6, decimal places = 0 

######.##  Length = 9, decimal places = 2 

#####.####  Length = 10, decimal places = 4 

The field length and decimal places for most numeric fields are user defined and can be 

modified with the Field Customization feature. Thus, if the default ####.## format of the 

Standard Hours field is not acceptable to you, you can change it to any reasonable length with 

up to four decimal places. 

The numeric separator and decimal symbol can be based on the PC’s regional settings or the 

company’s settings. For documents, the company’s settings are always used for numeric 

fields. In Company Setup these fields are currently inactive and set to display only. 

Object 
Object fields are used to store images. An example is the Employee Photo ID field. 

 

Path  
Path fields store a directory path. Path fields work just like a text field in that any value can 

be keyed. However, when a path is entered, it is validated to determine if it actually exists. 

You cannot record a path that does exist or cannot be validated. Path fields are supported by 

the path popup. 

Text 
Text fields are the most common type of field. They vary in length from one character to 255 

characters and can contain almost any printable character on the keyboard. In a text field, you 

can enter the text in the field itself or use the multi-line editor popup (if available) to enter 

more than a single line of text.  

Many text fields are supported by tables. Tables are user-defined lists from which values can 

be selected. When a field is supported by a table, the table popup button will be displayed 

adjacent to the field itself. 

There are a number of attributes that can be assigned to text fields. These attributes determine 

how the contents of the field are displayed when the field is first retrieved from the database 

and immediately after a change has been made. 

 Email  

 Hyperlink  

 None  

 Proper Case  

 Social Security  

 Telephone 

 Upper Case  

 

Email causes the contents of the field to be validated for relevance as an email address. This 

also enables the Email popup to be displayed. 

 

For a Hyperlink, no formatting is done on the field, but this setting sets the Popup Type to 

Hyperlink, which makes this field a hyperlink to whatever website, ftp site or file is in the 

field. 

 



Workbook 

 

24     Introduction to People-Trak 

None causes the field to remain as keyed. No action is taken on the field. 

 

Proper Case causes the contents of the field to be formatted according to standard proper case 

rules. Except for certain ethnic conventions (such as those used for Irish and Scottish names), 

this normally means that the first character of each word is set in upper case with the 

remainder of the name in lower case. Other phrases, particularly those used in an address 

such as RR, PO, etc., follow normal case conventions. 

 

Social Security causes the contents of the field to be formatted in one of the following ways. 

The actual format that you use is defined for the company using the Company Setup process. 

United States ###-##-#### 

Canadian  ###-###-### 

Telephone causes the contents of the field to be formatted in one of the following ways. The 

actual format that you use is defined for the company using the Company Setup process. 

(###) ###-#### 

###.###.#### 

### ### #### 

###-###-#### 

Upper Case causes the contents of the field to be forced to upper case. 

 

Note: Attributes for text fields can be changed using the Field Customization feature. The 

single quotation mark, double quotation mark, and bracket characters are not allowed in a text 

field. If these character keys are pressed, the keystrokes will be discarded. 

Time  
Time fields are used to store a time. The actual format used is based on the company’s 

settings. For documents, the company’s settings are always used for time fields. 

 

Time fields are supported by the time popup. It uses an hour list, minute list, and AM/PM 

indicates to allow you to pick a time using mouse clicks rather than keying the time directly. 

Yes/No 
Yes/No fields use check boxes to capture the Yes or No value. 

Popups 

People-Trak provides a number of popup features to enable you to complete the entries in 

fields. The following is a list of the standard popup

 Color 

 Date 

 Document  

 Email 

 Field 

 File 

 Font 

 Hyperlink 

 Path 

 Multi-Line Editor 

 Table 

 Time 

 

As the cursor is moved around on a screen, different popup buttons are displayed adjacent to 

the text boxes to indicate the availability of a popup. Each popup listed above has its own 

popup button. 
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Color Popup 

When the cursor is positioned to a color field, the only way you can select a color is to use the 

Color popup. When you click the popup button  in a color field, a screen similar to the one 

shown below is displayed with the current color in the large square. 

 

This popup allows you to select one of eleven basic colors or create a custom color. If you 

want to create a custom color, you can select Custom and then you will be taken to the more 

complex Color screen as shown below. 

 

This color popup provides a list of basic colors and custom colors, a color spectrum area and 

a color preview (Color|Solid) area. When the popup is first displayed, the color preview area 

shows the color attribute of the current field. You can select any other color by clicking on 

the appropriate color field. The field will be reflected in the color preview area. You can also 

select any color field and then change its spectrum settings on the right to create a custom 

color. If you want to save that custom color for future use, click on one of the available 

custom color fields and then click the Add to Custom Colors button to add that custom color 

to that location. When the appropriate color has been selected or created, click the OK button 

to return the color to the field, or you can click the Cancel button to return to the color field 

without taking any action. 

Date Popup 
When a cursor is positioned to a date field, you can enter a date in one of three ways. You can 

key the date directly, you can enter the date using the Date Stamp feature, or you can use the 

Date popup. If you click the popup button , the screen shown below is displayed. 
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When the date popup is first displayed, the calendar is adjusted to display either the date 

currently in the field or the current date if the field is blank. You can move around the 

calendars using the various buttons until the date desired is displayed. You can then click the 

OK button to return the date to the field, or you can click the Cancel button to return to the 

date field without taking any action. 

 

Document Popup 
When the cursor is positioned to a document field, you can enter the document name directly 

or you can select a document using the Document popup. When you click the popup button 

, the screen shown below is displayed.  

 

The document popup provides a list of document categories on the left and the documents in 

the highlighted category on the right. When you have located and highlighted the desired 

document, you can press ENTER, click the OK button or double-click the entry to return the 

document to the field, or you can click the Cancel button to return to the document field 

without taking any action. 

Email Popup 
When the cursor is positioned to a field supported by the email feature, you can click the 

popup button  and send an email using the Send Email screen shown below.  
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Field Popup 
When the cursor is positioned to a field supported by the list of fields in the module, you can 

enter the field name in one of two ways. You can enter the field name directly or you can use 

the field popup. If you click the popup button , the screen shown below is displayed. 

 

The field popup has a list of field categories on the left and a list of the fields in the current 

category on the right. There are five different types of field categories, which are listed below 

in the order they are found in the listing on the left side of the Select Field screen:  

All Fields This category includes all of the fields (including derived fields) in     the 

current module in alphabetic order.  

Category Each of the regular data entry and compound (created for you by putting 

regular fields together, i.e. Full Name) fields in People-Trak is assigned to a 

category. All of the different categories are listed. 

Notes This category includes all of the note fields.  
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System This category includes system fields and is only available within   templates.  

 

To select a field, click on the appropriate category in the list on the left. The fields in that 

category will then be displayed on the right. When you have located and highlighted the 

desired field, you can press ENTER, click the OK button or double-click the entry to return 

the field name to the field, or you can click the Cancel button to return to the field without 

taking any action. 

File Popup 
When the cursor is positioned to a File field, you can enter a file in one of two ways. You can 

key the entire path and filename or you can use the file popup. If you click the popup button 

, the screen shown below is displayed. 

 

The file popup allows you to move through drives, folders, and files until you find the desired 

file, just like Windows Explorer. The current path and file is displayed in the text box at the 

bottom of the form. When the desired file has been selected, you can click the OK button to 

return the complete path and filename to the field or you can click the Cancel button to return 

to the file field without taking any action. 

Font Popup 
When the cursor is positioned to a Font field, the only way you can select a font is to use the 

Font popup. If you click the popup button , the screen shown below is displayed. 
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The font popup allows you to select the font name, the font style, and the font size. A preview 

section also allows you to see just what the font looks like with those attributes. When the 

popup is first displayed, the current settings for the name, style, and size are selected and the 

preview also reflects these settings. You can select any combination of these settings and 

monitor the visual effect in the preview section. When you are satisfied with your selections, 

you can click the OK button to return the three values to their respective fields on the screen, 

or you can click the Cancel button to return to the font field without taking any action. 

Hyperlink Popup 
When the cursor is positioned to a hyperlinked field, you can execute the hyperlink by 

clicking on the popup button . A hyperlinked field can contain a website address, ftp site 

address or a filename. EXE and BAT files are not allowed. 

Path Popup 
When the cursor is positioned to a Path field, you can enter a path in one of two ways. You 

can enter the entire directory path or you can use the path popup. If you click the path popup 

button , a Select Path screen similar to the Select File screen is shown, except that no files 

are displayed or can be selected. 

Multi-Line Editor Popup 
When the cursor is positioned to a multi-line field, you can key short phrases directly into the 

field. However, if you wish to key more text, or if you wish to view text that is not visible on 

the multi-line field, you should use the Multi-Line Editor popup. If you click the popup 

button , the screen shown below is displayed. 

 

The multi-line editor popup allows you to key text using the ENTER key and with full 

scrolling features without the cursor moving to other fields. While the multi-line field on the 

original screen has a fixed size, the multi-line editor adjusts to fit the amount of text that has 

been entered. Thus, the editor not only acts as a place to key information, it allows you to 

view information that would not otherwise be visible. 

When the desired text has been keyed or modified, you can click the OK button to return the 

text to the field, or you can click the Cancel button to return to the field without taking any 

action. 

Tables and the Table Popup 
People-Trak makes extensive use of tables. Tables are lists that contain user-defined or 

system-defined entries. These lists are available to assist in filling the corresponding fields in 

a given record. For example, the State field is a table field. Behind the State field is a table 
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containing a list of states. When the cursor is positioned to the State field, the table can be 

used to validate the state code entered, or to directly select the state from the table. 

People-Trak utilizes both “system” tables and “user” tables. System tables are those that have 

been pre-defined within the product. These include custom report operators, links, date 

substitution variables and others, and cannot be changed. User tables are defined for use 

within the system, but are filled by the user as needed. User tables include cities, states, 

codes, and many others. 

Table Validation 

The validation of entries against each individual table can be set to three different levels: 

None, Optional, and Mandatory. When there is no validation (None), the table is simply 

ignored. When validation is Optional and a non-matching entry is made, the following 

message is displayed: 

Entry is not in the table, Override Table? 

Because the table is optional, the value can be accepted even though it is not in the table. To 

override the table and leave the entry, enter Yes. To discard the entry, enter No. 

When validation is Mandatory and a non-matching entry is made, the following message is 

displayed:  

Entry is not in the table 

When any key is pressed, the entry is discarded and the cursor is returned to the field. 

Note: When an optional table entry overrides the table, that entry is NOT moved into the 

table automatically. If you wish to move the entry into the table, it must be done using the 

table entry feature for that table. 

Data Entry Using Tables 

Table entries can be inserted into the record being edited in two ways. The first way is using 

the popup. The popup can be activated in two ways: the F3 key or the Table popup button  

adjacent to the field itself. When the popup is activated, the Select Tablename window is 

displayed. A sample is shown below. 
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An entry can be selected using standard techniques or manually entered. If that table has 

mapped fields, they are automatically inserted into the record being edited, changed to the 

modified color and set to display only. 

Tables are not available at every field. Whenever a table is available, the Table popup button 

is displayed to the immediate right of the field.  

Note: The fields that are supported by tables and the tables used to support fields can be 

modified at any time using the Field Customization feature. It is possible to add table support 

to any text box based field. Table maps are maintained in the Map Table Fields utility. 

Table Auto-Positioning 

When you pop up a table and the field already contains an existing entry in the table, the 

current value is selected and highlighted. 

 

Time Popup 
When the cursor is positioned to a time field, you can enter a time in one of two ways. You 

can key the time directly or you can use the Time popup. If you click the popup button , 

the screen shown below is displayed. 

 

The time popup provides a list box for the hour, a list box for the minutes, and two radio 

buttons to select AM or PM. When the time popup is first displayed, the list boxes and the 

radio buttons are adjusted to reflect the current value of the field if the field is not blank or the 

current time if the field is blank. You can use the features of the screen until the desired time 

is displayed. You can then click the OK button to return the time to the field, or you can click 

the Cancel button to return to the time field without taking any action. 

Search Feature within Field, Document and Table Popups 
In field, document and table popups, you can enter a single character or multiple characters to 

jump to the first entry that starts with that character or characters. For example, when in one 

of these popups, if you enter the letter “S”, you will be taken to the first entry in the popup 

that starts with the letter “S”. If you wait two seconds or more and then type in the letter “A”, 

you will be taken to the first entry in the popup that starts with the letter “A”. If you type in 

the letters “SAN” quickly, you will be taken to the first entry that starts with the letters 

“SAN”. 

Key Functions 
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The following is a list and description of the standard key functions, in alphabetic order.  

BACKSPACE  
Moves the cursor to the left one character while deleting the character on which the cursor is 

sitting. 

CTRL + PAGE DOWN  
Selects the next available record in the record dropdown. If the last record is the current 

record, the first record becomes the current record and is displayed. This feature is only 

applicable when editing records. The next record function is also available using the Next 

Record button on the Tool Bar. 

CTRL + PAGE UP  
Selects the previous record in the record dropdown. If the first record is the current record, 

the last record becomes the current record and is displayed. This feature is only applicable 

when editing records. The previous record function is also available using the Previous 

Record button on the Tool Bar. 

DELETE  
Deletes the currently highlighted text within a field. If no text is highlighted, it will delete one 

character of text at a time. 

DOWN ARROW 
 Moves the cursor from the current field to the next field. If the cursor is positioned to the last 

field on the screen, it is moved to the first field on the screen. On a grid, the DOWN ARROW 

key moves the cursor down one row while remaining in the current column. 

END 
 Moves the cursor to the end of the current field. 

ENTER 
 Moves the cursor to the next field. On a screen, the ENTER key will cause the cursor to 

cycle through all of the fields. When the cursor is positioned to the last field on the screen, 

the cursor will move to the first field on the screen. On a grid, if the cursor is positioned to 

the last field in a row, the cursor moves to the first field on the next row. 

F1 
Displays field properties and field help. SHIFT + F1 displays screen help. 

F2 
Invokes the Open Record feature. 

F3 
Invokes any applicable popup feature for the current field. 

F4 
On a Date field: Activates the date stamp feature and places the current value of the date 

stamp into the current field.On a Time field: Places the current time into the current field. 

F5 
Invokes the Run/Edit feature. 
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F6 
Invokes the Print Screen feature. 

F8 
Deletes the current row on a grid. All subsequent rows are pulled up to fill the deleted space. 

The Delete Row option is also available as an option on the Edit menu and as a button on the 

Tool Bar. 

F9 
Inserts a new blank row into a grid at the current row. All subsequent rows are pushed down 

to accommodate the new row. The Insert Row option is also available as an option on the 

Edit menu and as a button on the Tool Bar. 

 

F10 
Moves cursor to the first menu on the Menu Bar. (Microsoft Standard) 

HOME  
Moves the cursor to the beginning of the current field. 

LEFT ARROW 
 Moves the cursor from the current character in the field to the previous character in the field. 

If the cursor is positioned to the first character in the field, the cursor does not move. 

PAGE DOWN  
Selects the next available screen in the screen dropdown. If the last screen is the current 

screen, the first screen becomes the current screen and is displayed. This feature is only 

applicable when editing records. The next screen function is also available using the Next 

Screen button on the Tool Bar. 

PAGE UP 
 Selects the previous screen in the screen dropdown. If the first screen is the current record, 

the last screen becomes the current screen and is displayed. This feature is only applicable 

when editing records. The previous screen function is also available using the Previous 

Screen button on the Tool Bar. 

RIGHT ARROW 
 Moves the cursor from the current character in a field to the next character in the field. If the 

cursor is positioned to the last character in the field, the cursor does not move. 

SHIFT + TAB 
 Moves the cursor from the current field to the prior field. On a screen, SHIFT + TAB will 

cause the cursor to cycle through all of the fields. When the cursor is positioned to the first 

field on the screen, the cursor will move to the last field on the screen. On a grid, the cursor is 

moved backward one field on the current row. If the cursor is positioned to the first field on 

the row, the cursor is moved to the last field on the prior row. 

SPACEBAR  
Toggles a check box from selected to cleared or vice versa. 

TAB  
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Within a field, the TAB key is used to save the additions or changes that have been made and 

to move the cursor to the next field. The TAB key is also used to move the focus from one 

command button to another. 

UP ARROW  
Moves the cursor from the current field to the previous field. If the cursor is positioned to the 

first field on the screen, it is moved to the last field on the screen. On a grid, the UP ARROW 

key moves the cursor up one row while remaining in the current column. 

File Menu Functions 

The File menu is used throughout People-Trak to perform various file functions. Note: In the 

procedures below, it is assumed you are already in the appropriate item screen, and when you 

see the Item placeholder, this refers to the item that is using the procedure. For example, 

when you are copying an Adhoc Report, you need to be in the Explorer - Adhoc Reports 

screen and the Copy Item phrase is actually Copy Adhoc Report on the File menu. 

New 
Creates a new item with an item name of “NEW-” followed by a sequential number. For 

example, if you create a new Adhoc Report, the report name will be NEW-1. If that report 

name already exists, the report name will be NEW-2, and so on.  

Save 
Saves the current item to the database and stays in that current item. 

Delete 
Deletes the current item from the database.  

Copy 
Creates a new item just like the New function, except with an item name of the copied item’s 

name with “-1” appended. If the “-1” item name exists, the name of the new item will have a 

“-2” appended, and so on. It then copies the original item over that new item. For example, if 

you copy the Alphabetic Employee List document, a new document with the name 

Alphabetic Employee List-1 is created as an exact copy of the original document. If that 

report name already exists, the report name will be Alphabetic Employee List-2, and so on. 

Field Help  

Field help is available at any field and can be activated by using the F1 key or the Show Field 

Help button on the Tool Bar. When this option is used, the Field Name help screen is 

displayed with an overview of the selected field. 

There is also a Usage tree view that provides a listing of places where this field is used. This 

information can be very helpful in determining all of the places the field is used and how it is 

updated. If you would like to view the help text for a usage item, select that item in the list 

and the description will be displayed in the viewing area. 

Properties and attributes related to the field are displayed within the Properties and Attributes 

frame. 

 

Screen Help 
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Screen help is available at any screen and can be activated by using the SHIFT + F1 key 

sequence or the Show Screen Help button on the Tool Bar. If the screen does not have a 

Show Screen Help button, the key sequence will display Screen Help. When this option is 

used, the Screen Help screen is displayed with an an overview of the selected screen which 

includes screen properties. 

The Screen Objects tree view provides a listing of objects and fields used on the screen as 

well as their descriptions. 

 

There is also a Usage tree view that provides a listing of places where this screen is used. 

This information can be very helpful in determining all of the places the screen is used and 

how it is updated. If you would like to view the help text for a usage item, select that item in 

the list and the description will be displayed in the viewing area. 

 

Help Topics 

Help Topics are available from the Organizer desktop or any screen by using the Help Topics 

option on the Help menu. Selecting the Help Topics option displays the Help Viewer.  

Help documents can be accessed via the three tabs that are available on the left side of the 

screen and are easily viewed in the display area on the right. 

The Contents tab displays a preloaded list of reference documents when the Help Viewer is 

first selected. Contents displays a list of the documents in a three level tree view organized 

first by document, chapters within the document, and then by sections in each chapter. The 

document and chapter levels contain descriptions about the particular document or chapter. 

Articles can be selected at the section level. Once an article in the section level is selected, it 

can be read in the display area. 

The Index tab displays an alphabetic list of contexts. Once an article in the list is selected, it 

can be read in the display area. 

The Search tab article results are blank when the Help Viewer is first opened. To search 

articles, enter the desired phrase or text in the search box and select the Go button. All articles 

containing the phrase in the heading or article contents will be returned to the Search pane in 

list format. Once an article in the list is selected, it can be read in the display area. 

When an article under any of the tabs is selected, it is displayed in the right hand area of the 

screen. The article will remain in the display area until a new article is selected. Switching 

tabs will continue to display that same article until a new search is performed or another 

article is selected. 

Support Online 

This option allows you to connect to the People-Trak customer support website. On the 

support website, you can download patches, review newsletters, provide feedback, and 

communicate with your Support Representative.  

Help About 

This option displays your People-Trak license and options information.  
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Notes 
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This lesson covers some of the essential tasks to get started with People-Trak as well as the 

three different People-Trak views, known as desktops. 

Tutorials 
Start People-Trak: shows how to start People-Trak and get logged in. It also goes over how 

the login process works. 

Menu Navigation:  demonstrates how to navigate the People-Trak menus. 

Organizer Desktop: covers the Organizer desktop, where administrative tasks are done and 

processes are accessed by module. 

Changing the Current Company: demonstrates how to change the current company. 

Stop People-Trak: shows how to close open screens and stop People-Trak. 
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Tutorial 1.1 – Start People-Trak 

Let’s learn how to start People-Trak and then take a look at the login process.  

1. Start People-Trak by double-clicking on the People-Trak Trainee icon on your desktop 

(or as instructed).  

 

The Select Product Option screen is displayed. This screen is used for training purposes 

and allows you to set the product options applicable to your particular training 

session.  All of the basic training classes use the base People-Trak product with only the 

Position Control and Attendance options selected. The Select Product Options screen 

toggles these options when the Training button is selected. Since most People-Trak 

customers have implemented the Position Control and Attendance options, training is 

normally performed with those options selected. If you are not currently using these 

options, you will learn about them and see some of their capabilities within the training 

courses. 

2. The Position Control and Attendance options should be the only options that are 

toggled on. If not select the Training button to select them. 

3. Click OK 

 

The Login screen is displayed. The Login screen is the gateway to People-Trak. The User 

ID/Password combination you enter here determines which processes you can use and 

which information you can see. When the Login screen is displayed, the cursor is 

positioned to the User ID field. Let's learn a few things about entering user/password 

combinations as well as other information in People-Trak. 

4. In the User ID field, enter DEMO and press TAB.  

 

The cursor moves to the Password field.  

5. In the Password field, enter BOGUS, but do not press the TAB or ENTER key.  

 

As the password is entered, note that an asterisk is displayed for each character entered. 

The asterisks are displayed to represent the characters being typed. The actual characters 

of the password are not displayed for security reasons. 

6. Press ENTER when complete or click the OK button. 

 

The following message is displayed because the password BOGUS is indeed bogus: 

7. Invalid login 

8. This message and all similar messages are displayed in a message box. The message box 

pops up to get your attention and is cleared when you take the appropriate action. In this 

case, the message box contains a single button. You can press ENTER to select the action 

indicated by the button, or you can use the mouse to click the button. 

9. Press ENTER to continue.  

 

The User ID and Password fields are cleared and the cursor is returned to the User ID 

field so that you may try again. Each time you run People-Trak, you have three attempts 

to enter a correct user/password combination. If the third attempt fails, People-Trak 

closes. Let's demonstrate this. 
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10. In the User ID and Password fields, enter BOGUS. This time, use the mouse to click the 

OK button. Repeat this process one more time.  

 

After the third attempt, People-Trak closes. People-Trak has assumed that you are an 

unwanted intruder because you do not know a valid password, so you are forced to start 

over. This may seem rude, particularly if you tend to forget your password or make a lot 

of typing errors, but it does thwart hackers who will sit for hours trying to break the 

security. 

11. Run People-Trak again by double-clicking on the People-Trak Trainee icon on your 

desktop. 

12. The Position Control and Attendance options should be the only options that are 

toggled on. If not select the Training button to select them. 

13. Click OK 

 

The Login screen is again displayed. 

14. In the User ID field, enter DEMO. In the Password field, enter DEMO. Then press 

ENTER.   

 

The People-Trak Organizer screen is displayed. The Personnel Management module is 

selected for you and is highlighted in the Modules listing. The Personnel Management 

module is just one of several standard modules that are used to capture and use data in 

People-Trak. 

15. Continue with the next tutorial. 
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Tutorial 1.2 – Menu Navigation 

When you first select a module you can start virtually all of the options in that module. As 

you will see later, once a record or another process has been selected, or if a new record is in 

progress, many options are disabled to avoid processing conflicts. For now, let's learn how to 

navigate in People-Trak. 

1. First, make sure that the Personnel Management module is still highlighted in the 

Modules listing. If it is not highlighted, click Personnel Management to select that 

module, which will highlight it. 

 

People-Trak uses standard Windows operating conventions. You can see the Menu Bar at 

the top of the screen. You can activate the menu using the mouse to click the menu 

caption, (or you can press ALT and the underlined letter in the menu title for you 

keyboard people). Let's try it now. 

2. Use the mouse to click on the File menu.  

 

The menu drops down and lists the various options that are available. You can highlight 

and select any available option. We'll do that later. For now, let's close the menu. 

3. To close a menu, move the mouse off the menu and click.  

 

The menu is closed. You can also close a menu by pressing the ESC key.  

 

Now is a good time for you to peruse each of the menus.  

4. Using the desired technique, select each of the menus listed and review the menu. Do not 

select any of the menu options themselves at this time. Once you have made yourself 

familiar with the menus, continue with the next step. 

5. Now it's time to select an option from one of the menus. First, click the File menu and 

then select the Open Employee option.  

 

The Lookup Employee screen is displayed. We'll learn more about this later.  

6. For now, click the Cancel button to close the Lookup Employee screen.  

 

This is really all there is to menu navigation. Certain menu options will display other 

menus, but in each case these same operating conventions apply. 

 

Now that you know how to navigate menus, we can start exploring the desktop. 

7. Continue with the next tutorial. 
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Tutorial 1.3 – Organizer Desktop 

Now, let’s take a look at the Organizer desktop. 

The overall screen environment that you are currently viewing is known as the Organizer 

desktop. The Organizer desktop has a Menu Bar across the top and a Shortcut Bar down the 

left side. It also has four areas, which we will refer to as “panes”: Modules, Categories, Tasks 

and People-Trak News.  

 

We have already learned about menu navigation so let’s look at the Shortcut Bar, which 

provides shortcut icons much like Microsoft Outlook. These icons are used to activate 

frequently performed tasks such as creating records, opening records, showing the Inbox, etc. 

All of the shortcuts are also listed on the menus at the top of the screen. Let’s take a look. 

1. Open the File menu.  

 

Many of the shortcuts come from the File menu as you can see here. The little icons at 

the left edge of the menu are smaller versions of the same icons used in the shortcuts. 

Both the shortcut and the menu options will start the option. We provide both for your 

convenience. Each user will settle into his or her personal way of using the product.  

2. On the File menu, select Open Employee. 

 

The Lookup Employee screen is displayed.  

3. Click the Cancel button to close the Lookup Employee screen.  

4. On the Shortcut Bar, click the Open Employee shortcut.  

 

Once again, the Lookup Employee screen is displayed.  

5. Close the Lookup Employee screen again.  

 

You see, the File menu options and the shortcuts perform the same task. 

 

When we started People-Trak, the first module in the Modules pane, Personnel 

Management, was highlighted. It became the current module by default. When you used 

the Open Employee options to select a record, an employee record from the Personnel 

Management module was selected. We can, however, use the features in any module. 

Let’s select another module now. 

6. Select the Safety Management module by clicking on that name in the module list. 

 

You can see that changes, based on the new module, have occurred in the following three 

areas of the screen: the Menu Bar options, the Shortcut Bar icons, and the Organizer 

categories.  

7. Use what you have just learned and return to the Personnel Management module. 

 

In all modules, the various screens, tables, reports, activities, and processing options have 

been divided into categories. You can see the list of categories for the Personnel 

Management module in the Categories pane of the desktop. This pane utilizes a tree-view 

control that allows you to expand and contract the entries to show additional entries. 

Let’s use tree-view navigation now. 
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8. Click the “+” sign adjacent to the Attendance category.  

 

Note that the category opens up to display a list of subcategories. For each category, the 

available subcategories are the same, but not all may be shown. The subcategories 

include: activities, processing, documents, tables, and workflows. If a category has 

options in one of these subcategories, the subcategory will be shown. Now, let’s open up 

a subcategory. 

9. Click the “+” sign adjacent to the Processing subcategory to display a list of the 

processing menu options associated with the Attendance category.  

10. Click the “+” sign adjacent to the Documents subcategory to display a list of the 

documents available in the Attendance category. Click the “-” sign adjacent to the 

Documents subcategory to close that subcategory. You can move among the categories 

and subcategories quite readily, opening and closing as you see fit. 

 

The options listed are not merely listed for organizational purposes. You can run the 

option right from the organizer.  

11. In the Processing category for Attendance, click the Attendance Batch by Employee 

option to select it.  

 

The data entry screen for that option is displayed, just as if you had selected the option 

from the menu.  

12. Close the Attendance Batch by Employee screen by clicking on the X in the upper 

right-hand corner of that screen. 

13. Find this option on the Processing menu itself and select it there.  

 

As you can see, there are two entirely different ways of selecting options.  

14. Close the Attendance Batch by Employee screen. 

 

The Tasks pane allows you to have activities, documents, processing, tables, links and 

workflows available in a simple list. This one list can have tasks from any module and 

allows you to have a “my world” view of People-Trak. This Tasks pane stays the same no 

matter what module is selected. Let’s demonstrate this while learning how to navigate 

this pane. 

 

Tasks can be grouped however you choose. We have already selected and grouped some 

tasks for the DEMO user and those groupings are listed in the Tasks pane in the order 

they are listed in Desktop Setup. You can open a group just like you opened a category in 

the Categories pane. 

15. In the Tasks pane, click the “+” sign adjacent to the first group name.  

 

The tasks in that group are displayed. 

16. Click the “-” that is now displayed next to that group name to close that group. Simple. 

17. Now, open all of the task groups so you can see all of the tasks, which are from several 

modules.  

 

Now, we want to see if these tasks change when you switch modules. 
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18. Switch to the Safety Management module and check the Tasks pane. Are they the 

same? 

 

Yes! You can work from your Tasks pane and have the same list no matter what module 

you are in currently. When you select a task from a different module than you are in 

currently, you will be automatically switched to the correct module and the task will be 

executed. When the task is completed, you will be returned to the module you were in 

when you selected the task. Let’s see how this works. 

19. You should still be in the Safety Management module. In the Tasks pane under the My 

Workflows category, click the Standard - Applicant option to select it.  

 

The module is automatically switched to Applicant Management and the Lookup 

Applicant screen is displayed. 

20. Click Search and then click OK to select all applicants. 

 

The Standard - Applicant workflow is opened.  

21. Close the Standard - Applicant workflow by clicking on the X to the far right of the 

Standard - Applicant title. 

 

You are automatically returned to the Safety Management module, which you were in 

when you selected the task. 

22. In the Tasks pane under the My Activities category, select Candidate Manager.  

 

This is a feature in the Position Control module that allows managers and recruiters to 

view and update both open positions and the candidates who have applied. Again, you 

did not have to switch to the Position Control module or locate the Candidate Manager on 

the appropriate menu. People-Trak did that for you.  

23. Close the Candidate Manager. 

 

As you can see, using the Tasks list is a much faster and easier way of running 

commonly-used tasks. 

 

The People-Trak News pane includes links to the latest information provided by People-

Trak. The links in this area will be updated nightly when running the NightRun process. 

You can view video tips, customer notifications and other important information to keep 

you up-to-date. There will be up to ten links as well as an Archive link, which accesses 

an index of past news items. 

24. In the People-Trak News pane, simply click on any link to access that news item. 

 

The web browser is opened and uses that link. 

25. If you are taking this class via WebEx, close the tab for that link on your web browser 

(leaving your WebEx tab still open) and press ALT + TAB to return to People-Trak.  

If you are not taking this class via WebEx, close your web browser, and you will be 

returned to People-Trak. 

 

Take a quick look at the Status Bar, which is located at the bottom of the desktop. It 

contains panels for messages, a progress monitor (both blank at the moment), the People-
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Trak version, the database type, the system date, the user type and the record counter (the 

current number of employee records used out of the total number of licensed records). 

26. Continue with the next tutorial. 
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Tutorial 1.4 – Changing the Current Company 

You can change the current company to any other company to which you have access. 

1. On the File menu, select Select Company or on the Shortcut Bar, click the Select 

Company shortcut. 

 

The Select Company screen is displayed. A list of the companies to which you have been 

granted access (not including the current one) is displayed in the list on the left and the 

first company is highlighted. Information for the selected company is shown on the right. 

None of this information can be changed on this screen. To edit the company 

information, you must use the Company Setup process on the Setup menu.  

 

Note: If you only have access to one company, the Select Company feature is not 

available on the File menu and is disabled on the Shortcut Bar. 

 

To select a company, highlight the company name and click OK.  

2. Go ahead and select the ARCHIVE company.  

 

The ARCHIVE company’s logo and name are displayed in the Header. 

 

You may now continue processing just as before except that all processing will now be 

within the company to which you have just switched. Nothing else has changed. You are 

just working with a different collection of data. 

 

Let’s switch back to the ACTIVE company. 

3. Use the Select Company process to switch back to the ACTIVE company. 

4. Continue with the next tutorial. 
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Tutorial 1.5 – Stop People-Trak 

Screens can be closed using the two standard Windows methods. You can use the Close (X) 

button in the upper right-hand corner of the screen, or you can use the appropriate option on 

the File menu. If you have made any changes and you use the File menu, the changes are 

automatically saved. If you have made changes and use the X button, you will be prompted to 

save the changes in process. If any screens are in use when it is time to exit, that screen and 

any other open screens must first be closed. Let's set up this scenario and then exit. 

1. On the Tools menu, select Maintain Tables. From the list of tables on the right, select 

the Allergy table and click the Edit button. 

 

Unofficially, you are now editing the Allergy table. Now let's assume that it's time to go 

to lunch and you wish to exit. 

2. On the File menu, select Exit or click the X in the upper right-hand corner of the screen.   

 

Since you didn’t make any changes to the table, both of these options will just close the 

Allergy screen and return you to the Maintain Tables screen.  

3. Click the Close button to close the screen. 

4. On the File menu, select Logoff DEMO or on the Shortcut Bar, click the Logoff 

shortcut. 

 

The Login screen is displayed. On the Login screen, you can either log in again, or you 

can exit. We’ll try both.  

5. First, log in with DEMO/DEMO.  

6. Once logged in, click the Logoff shortcut to log off again.  

 

The Login screen is displayed. 

7. This time, click the Cancel button to close the Login screen and exit People-Trak.  

 

You can also exit People-Trak directly from one of the desktops. Let’s give that a try. 

8. Run People-Trak again by double-clicking on the People-Trak Trainee icon on your 

desktop.  

9. The Position Control and Attendance options should be the only options that are 

toggled on. If not select the Training button to select then and click OK. 

10. When the Login screen is displayed, login as DEMO/DEMO. 

11. Click the X in the upper right-hand corner of the Organizer desktop.  

 

The following message is displayed: 

Do you wish to exit People-Trak? 

12. Click Yes. You can use this method from any desktop.  

13. Continue with the next tutorial. 
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This lesson gives you a tour of the Workflow Area and covers the fundamentals of how to 

navigate screens and subscreens. It also covers data validation and formatting examples. 

Tutorials 
Workflow Area: tours the workflow area available when a record is open for processing. 

Screen Navigation: demonstrates multiple ways to navigate People-Trak screens. 

Selecting Subscreens: shows how to select subscreens in People-Trak. 

Data Validation: covers how data is validated during data entry. 

Formatting Examples: gives some examples of how the different formatting attributes of 

fields work. 
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Tutorial 2.1 – Workflow Area 

When you open a record for processing, you are in what we refer to as the “Workflow Area”. 

In this tutorial, you will take a tour of the Workflow Area to get more familiar with it. 

1. Run People-Trak again by double-clicking on the People-Trak Trainee icon on your 

desktop.  

2. The Position Control and Attendance options should be the only options that are 

toggled on. If not select the Training button to select them and click OK  

3. When the Login screen is displayed, login as DEMO/DEMO.  

 

The Personnel Management module becomes the current module. 

4. On the File menu, select Open Employee or on the Shortcut Bar, click the Open 

Employee shortcut or press the F2 key to open an employee.  

 

The Lookup Employee screen is displayed.  

5. Click the Search button to display the list of records for the current company. Select 

Donald Stern from the list by double-clicking on that row (or highlighting the row and 

clicking OK). 

 

You have now entered into the Workflow Area. Like the desktop, there is a Menu Bar 

starting with the File menu. 

 

Let’s peruse these menus like you did on the desktop. 

6. Select each of the menus listed and review the menu. Do not select any of the menu 

options themselves at this time. Once you have made yourself familiar with the menus, 

continue with the next step. 

 

Right below the Menu Bar is the Tool Bar. Each button on the Tool Bar has a graphical 

icon on it that helps denote what it is. These icons are also used on the File menu. Let’s 

take a look. 

7. Click on the File menu and look at the icon next to New Employee. It is an open folder 

with a sunburst. Close the menu. 

8. Look at the first button on the Tool Bar. Its icon is the same so it must be New 

Employee. Let’s find out how to know what this button does. 

 

If you move the mouse over a button on the Tool Bar and right click, a tooltip will 

display giving a description of that button. 

 

Now, let’s take a look at some tooltips. 

9. Start with the first button on the Tool Bar and move the mouse over that button and right 

click. 

 

You will see that the first button has a tooltip of New Employee. Just as we thought! 

10. Now, perform the same action for each of the buttons on the Tool Bar to familiarize 

yourself with what each button does. If a button is dimmed, it is disabled. 
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Immediately below the Tool Bar are the Navigation and Category bars. The Navigation 

Bar contains the Records section which contains features for navigating groups of 

records. The Category Bar contains the Screen dropdown for navigating the various 

screens available in the current module and features four category buttons. You will learn 

about record navigation in Data Entry training. We will take a look at screen navigation 

in the next tutorial. 

 

For now, let’s see what those last four buttons do. 

11. Right click on each of the buttons at the far right of the Category Bar to discover what 

each does. 

 

Now that you are familiar with the Workflow Area you are ready to begin using it. 

12. Continue with the next tutorial.  
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Tutorial 2.2 – Screen Navigation 

It takes a number of screens to collect and display all of the information for an employee or 

applicant. This tutorial demonstrates multiple ways to navigate these screens. 

1. You should still be in Donald Stern’s record with the Personal screen displayed. 

 

The name of the current screen is listed in the Screen dropdown on the Category Bar. 

Look for the phrase Personal. This box acts as both a label for the current screen as well 

as a list box for selecting any of the other screens. Let's use this Screen dropdown to 

select a different screen now. 

2. Use the mouse to click on the arrow button connected to the Screen dropdown. A list of 

the available screens is displayed. Click the Status screen to select it.  

 

The Status screen with the status information for Donald Stern is displayed. 

3. Try it again. Select any of the screens listed and view the information.  

 

There are a couple of other techniques that can be used to move to another screen. Let's 

try these now.  

4. Find the green arrow buttons just to the right of the Screen dropdown. Click the Right 

Arrow button.  

 

The next screen is displayed and the screen name in the Screen dropdown is updated. The 

next screen that is displayed is always the next screen relative to the current position in 

the Screen dropdown. For example, if you are at the Personal screen and click the Right 

Arrow button, the Status screen will be displayed. If you are at the Status screen, the 

Compensation screen will be displayed. If you are at the last screen in the list, the first 

screen will be displayed.  

 

You have probably already guessed, but the left arrow acts identically to the right arrow 

except in the opposite direction.  

5. Click the Left Arrow button now.  

 

Again, note how the screen name in the Screen dropdown is updated to let you know 

where you are.  

 

There is one final method for browsing through the screens using keys on your keyboard. 

The PAGE UP and PAGE DOWN keys perform the same functions as the Right and Left 

Arrow buttons.  

6. Try the PAGE UP and PAGE DOWN keys now.  

 

The succeeding and preceding screens are displayed and the screen name is updated in 

the Screen dropdown. 

 

Any of these techniques can be used at any time. There is no right or wrong way. You 

will find that it takes two clicks on the mouse to pick any screen using the Screen 

dropdown, while it can take multiple button presses or PAGE keys to move to the desired 

screen. The particular techniques you use in any particular case will become second 

nature as you grow accustomed to People-Trak. 
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7. Use any desired technique to return to the Personal screen.  

8. Continue with the next tutorial. 
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Tutorial 2.3 – Selecting Sub Screens 

There are both full-screen data entry screens, referred to as “primary” screens, listed in the 

Screen dropdown and sub screens that are used to capture and display additional information 

that is related to the general category defined by the primary screen. For example, on the 

Personal primary screen, there are sub screens for emergency contacts, dependents, education 

and experience, just to name a few. Let's show you some sub screens and how to select them. 

1. You should still be in the Personal screen for Donald Stern. 

 

Note that there are four large buttons on the right-hand side of the Personal screen. Each 

of these buttons is labeled with the name of a sub screen.  

 

The technique used to display a sub screen is quite simple. Just use the mouse to click on 

the button.  

2. Click the Emergency button.  

 

The Emergency Contacts sub screen is displayed so you can view the additional 

information regarding the emergency contacts for Donald Stern. 

 

Each sub screen has a Menu Bar, Tool Bar and Navigation Bar as well as an X in the 

upper right-hand corner. When you are finished viewing, changing, or adding 

information, simply use the X or the Exit option on File menu to exit. If you have made 

any changes and you use the File menu, the changes are automatically saved. If you have 

made changes and use the X button, you will be prompted to save the changes in process. 

Let’s use the X button and see how that works. 

3. Make a simple change to the Emergency Contacts sub screen. Then click the X button 

to close the sub screen.  

 

The following message is displayed: 

Do you want to save the changes in process?  

4. Click the Yes button to save the changes from this visit to the sub screen.  

 

Note: By clicking Yes, you are ensuring that the changes you made in this sub screen 

stay active. The changes are not saved to the database until the record itself is saved. 

 

If you had clicked the No button, the changes (any and all) would have been ignored. If 

you had clicked the Cancel button, you would have been left on the sub screen to 

continue processing. 

5. Click the Emergency button to go back into the Emergency Contacts sub screen. 

 

As you can see, your change is still there in the modified color, which is red in the current 

color scheme. 

6. Click the X button to close the sub screen. 

 

You aren’t asked to save any changes because you didn’t make any further changes in 

that editing session. 
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7. Click the Emergency button to go back into the Emergency Contacts sub screen. 

 

Your change is still there. If you had made a change in the second editing session and did 

not save that change, your first change still would have been there. 

8. Click the X button to close the sub screen. 

 

Once you have selected a sub screen, you cannot select another sub screen until you 

return to the current primary screen. 

9. To see for yourself, click the Dependents button. While the Dependents screen is 

displayed, try clicking the buttons for all of the other sub screens. 

 

As you can see, they are disabled. 

10. Close the Dependents screen. 

11. Now try the sub screens for Education and Experience just to show that sub screens all 

work alike. 

 

The sub screens on each screen are of the same subject matter as the screen itself. You 

can see this for yourself by browsing through each of the screens and viewing the sub 

screens. Try it now.  

12. Browse through the primary screens and take a look at what sub screens are included on 

each. 

13. Continue with the next tutorial. 
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Tutorial 2.4 – Data Validation 

Data validation protects the database from receiving incorrect or inappropriate data from the 

data entry process. Data is validated during data entry both when keys are pressed and when 

you leave the field.  

1. Use your newly acquired screen navigation skills to select the Compensation screen. 

Then, in the Current Pay frame, click in the Pay Rate field.  

 

The Pay Rate field is a numeric field and can only accept numeric values.  

2. Try entering a few characters and then try a few numbers. Finally, try the period (decimal 

point) and the dash. The dash is needed because it is used to indicate negative (less than 

0) numeric values. You cannot enter the dollar sign.  

 

This is an example of data being validated when keys are pressed. Let’s look at one more. 

3. Return to the Personal screen. 

4. In the Birth Date field, highlight the contents of the field and then press DELETE to 

clear the field. Try entering 03-. 

 

Nothing happens when you press “-”. If you tried “/”, that wouldn’t work either.  

5. After the 03 that is already showing, try entering 22. 

 

Voilà! The date now reads 03-22. 

 

Note: People-Trak uses your PC’s regional format settings for dates. Our date examples 

assume a “m-d-yyyy” date format. You can change your PC’s regional settings using the 

Windows Control Panel and going into the Regional and Language Options. We won’t 

take the time now to have you make that journey, so if this is something you are 

interested in doing, contact your Support Representative if you have questions on this 

topic. 

6. Now type in 1963 after the 22. 

 

The date should now read “03-22-1963”. People-Trak automatically put in the date 

separators for you. This is an example of data validation when keys are pressed (only 

allowing numbers) and entry formatting (automatically putting in the separators) all-in-

one. We will take a closer look at entry formatting in the next tutorial. 

 

Now let’s look at data validation that is done when you leave a field. 

7. In the Birth Date field, enter 33-33-3333 and press ENTER.  

 

Note: The phrase “enter” in “enter 33-33-3333” means to first clear any existing data in 

the given field and then enter the data as directed. This is true here and in all further 

references to “enter” until we learn about popups, which will put a slightly different spin 

on this word. 

 

The following message is displayed: 

Invalid date 
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This date is invalid because there are only 12 months in a year and no more than 31 days 

in a month. 

8. Click OK to accept the message. 

 

Data entry errors are not always as obvious as this outrageous date.  

9. Go back to the Birth Date field and enter 06-31-2002.  

 

This looks like a valid date, but June has only 30 days. This error will be detected and the 

data entry rejected.  

10. Try entering a birth date of February 29 in a non-leap year.  

 

The invalid data entry will be caught and rejected before it can be stored in the database. 

 

As mentioned, validation must occur whenever you leave the field, not just when you 

press the ENTER key or TAB key. Try this.  

11. Enter an invalid date, but do not press ENTER or TAB. Instead, try to select another 

screen as a way of getting past the error.  

 

You won’t make it. The error will still be detected and your bad date rejected. This same 

feature works with any field that requires validation including numeric fields that do not 

match the decimal pattern or size constraints of the field. You can try your own examples 

if you like. 

12. Continue with the next tutorial. 
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Tutorial 2.5 – Formatting Examples 

Formatting is the process of displaying data in a desired form. There are many ways to 

display numeric values and text phrases. The formatting attributes of each field are stored 

within People-Trak. These attributes can be changed using the customization features in 

People-Trak, but that is another lesson in another course. This tutorial will show how the 

formatting actually works. 

1. Click in the Last Name field. 

 

By default, the Last Name field has been provided with the “proper case” formatting 

attribute. In general, the proper case attribute makes the first character of each word 

upper case and makes the other characters lower case. 

2. Clear the Last Name field by double-clicking to highlight the field and then pressing the 

DELETE key. Enter the last name jones in full lower case and press ENTER.  

 

The last name will be reformatted to Jones.  

3. Try it again, but key the entire name in upper case. When you press ENTER, the last 

name will be formatted as before. 

 

The proper case attribute is reasonably smart when it comes to formal names.  

4. To see what we mean, enter the last name macdougal in any desired case pattern and 

watch what happens when you press the ENTER key.  

 

The last name is echoed in the format MacDougal as is appropriate. Most variations of 

names are handled correctly, as are common abbreviations such as RR, PO Box, etc. 

 

There are other formatting attributes for different types of fields and they work the same. 

If you enter the field in the wrong format, but the entry is valid, the entry will be 

formatted appropriately. For example, numeric fields have a formatting attribute that 

determines total length and decimal places. Let’s see how this works. 

5. Select the Compensation screen. In the Current Pay frame, click in the Pay Rate field.  

 

This field has the format “#########.##” which means that you can enter up to up to 

nine digits to the left of the decimal place and only two digits are allowed to the right of 

the decimal place. If you enter more than two digits to the right of the decimal place, the 

number will be truncated at the second decimal place.  

6. Enter ten 9’s. 

 

You receive a validation error because the entry is not valid according to the format, 

which specifies a max of nine digits to the left of the decimal place.  

7. Go back to the Pay Rate field and enter 4999.9. 

 

You will not receive a validation error, because the value is formatted to 4999.90.  

8. Go back to the Pay Rate field and enter 4999.999. 
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You entered three decimal places, so the number is truncated at the second decimal place, 

for a result of 4999.99. 

9. Select the Personal screen. 

 

Remember the entry formatting you saw in the Birth Date field in the last tutorial? Let’s 

look at it again. 

10. In the Birth Date field, enter 04-15-1960. 

 

As before, the “-” is entered for you. This is an example of entry formatting, which is 

unique to date fields. In our case, we are using the date format of “m-d-yyyy”, so the “-” 

was added for us. Let’s close Donald’s record, without saving changes. You can do this 

by clicking the X in the upper right-hand corner of a primary screen (not the X in the 

People-Trak bar). 

11. Click the X in the upper right-hand corner of the primary screen (in the Standard-

Employee bar). 

 

The following message is displayed: 

Do you want to save the changes in process? 

12. Click No to not save the changes. 

 

This is the only way to close a record without saving changes. You can also close a 

record by doing one of the following, but all of these ways automatically save your 

changes to the current record: 

 

a. Use the New Record  option on the File menu or Tool Bar 

b. Use the Open Record  option on the File menu or Tool Bar 

c. Use the Close Record  option on the File menu or Tool Bar 

d. Use the Exit option on the File menu  

e. Change to another record in the record group 

 

Note: Record stands for the name of the primary record for a module. In Personnel 

Management, the option would be Close Employee. 

13. Continue with the next tutorial.  
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Notes 
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This lesson covers how to work with grids, including inserting, deleting and sorting rows in a 

grid. It also covers how to undo changes in a field, as well as an entire screen. 

Tutorials 
Insert and Delete Rows in a Grid: shows how to insert and delete rows in a data entry grid. 

Sorting Rows in a Grid: shows how to sort rows in a grid. 

Undo Fields: demonstrates how to use the undo field feature to undo one or more changes in 

a field. 

Undo All Changes: demonstrates how to undo all changes made during the current session. 
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Tutorial 3.1 – Insert and Delete Rows in a Grid 

In this tutorial, you will learn how to insert and delete rows in a grid. 

1. Open Donald Stern’s record. 

2. Select the Performance screen.  

 

Note that Donald has multiple performance appraisal rows in the grid.  

 

There is no limit to the number of performance appraisal rows available, but only a 

portion of these can be seen at any one time. To view performance appraisal rows that are 

not in the viewable area, use either the DOWN ARROW key or the scroll bar on the 

right. (Remember, the PAGE DOWN key will move to the next screen.) When a grid is 

first displayed, the existing data is displayed plus 50 blank rows. If you need to enter 

more than 50 rows of new data, you can click the Save button and you will be given an 

additional 50 blank rows.   

 

When rows in a grid are dated, it is strongly recommended that the rows be maintained in 

descending order, with most recent date first. To do this you need to know how to insert 

rows. 

3. Check the Tool Bar and note that the Insert Row button is enabled. Click that button. 

 

Note that all subsequent rows are pushed down and that the current record is cleared for a 

new entry. You can insert a row for a new first record, or you can insert a row at any 

other row.  

4. Try inserting rows at any other row and do not worry about the blank rows.  

 

We'll learn how to delete rows next. 

5. Click in the first blank row you inserted. On the Tool Bar, click the Delete Row button. 

 

The row is deleted and all subsequent rows are scrolled up.  

6. Use the Delete Row button to delete any other rows you have entered. 

 

The Insert Row and Delete Row functions are also available by pressing the F9 and F8 

keys, respectively, and as options on the Edit menu. These functions are available for 

nearly all grids. In a few cases, rows are displayed and can be edited, but rows cannot be 

inserted or deleted. In those instances, the Insert Row/Delete Row buttons, menu options 

and function keys will be disabled. 

7. Stay on the Performance screen as we will be learning how to sort rows in this grid next. 

8. Continue with the next tutorial. 
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Tutorial 3.2 – Sorting Rows in a Grid 

In the last tutorial, we mentioned that rows on grids can be entered in ascending, descending, 

or totally random order. This may occur intentionally or unintentionally. Fortunately, you can 

sort these rows. You'll learn how in this tutorial. 

1. First, determine the order of the rows on the Performance Appraisals screen by looking 

at the Initiation Date column.  

 

The rows were originally recorded in descending order so that the most recent record is 

on top. Perhaps this is acceptable for your organization and perhaps it is not. Let's assume 

it is not. 

 

Sorting is almost always applicable for grids (it is disabled in a few cases) and is easy to 

perform.  

2. Click on the header for the Initiation Date column. 

 

The rows are now sorted in ascending order. 

3. Click on the header for the Initiation Date column again. 

 

The rows are now sorted in descending order again. As many times as you click, People-

Trak will reverse the sort order. 

4. To show that you can sort by any desired column, click on the Items Rating column to 

sort by that column. Click again to re-sort in the opposite order. You can try this with as 

many columns as you wish. 

 

Another way to sort rows in a grid is to use the Row Up and Row Down buttons. 

5. Click on one of the rows in the bottom half of the grid. On the Tool Bar, click the Row 

Up button. That row will move up one row. Continue to click on the Row Up button to 

move that row all the way to the top.  

 

Once you reach the top, clicking the Row Up button does nothing.  

6. Now, click the Row Down button several times, and the current row moves down. 

 

When you sort rows on a grid, the sorting is persistent. This means that the rows are 

stored back into the database in the order in which you last sorted them. We’ll 

demonstrate this. 

7. Sort the performance appraisals in some obvious order and then move to another screen. 

Now, return to the Performance Appraisals screen. Note that the rows are retrieved and 

displayed in the order in which you last left them. Sort the rows again and leave the 

screen and come back. Note that the sort order persists. 

 

People-Trak provides a capability to prevent specific users from sorting grids. This is 

something you may consider if rows are continually sorted in different order because 

users are too casual with their sorting. For example, you might have reports that are 

expecting the most recent information in the top row of a grid but someone sorted that 

grid in a completely different order. In this case, your report results will not be what you 

wanted. You can disable the grid sorting feature for a user in Security Setup. 
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Before we continue on with the next tutorial, let’s close Donald’s record without saving 

the changes we just made. Remember how to do that?  The following step is a reminder.  

8. Click the X in the upper right-hand corner of the primary screen (in the Standard-

Employee bar), and then click No to not save the changes. 

 

In future tutorials, when you are asked to close a record without saving the changes, that 

is what you will need to do. 

9. Continue with the next tutorial. 
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Tutorial 3.3 – Undo Fields 

Undo is a powerful feature that lets you correct mistakes and return data to a prior state. 

Here’s how to use the feature on a field-by-field basis. 

 

To demonstrate the Undo feature, we need to make changes to some fields. Rather than just 

making changes, we will demonstrate the cut, copy, and paste feature of People-Trak to make 

these changes. 

1. Open Donald Stern’s record. 

 

The Personal screen is displayed. 

2. Click in the Country field. On the Edit menu, select Select All or use the mouse to select 

the contents of the field.  

3. On the Edit menu, select Cut or on the Tool Bar, click the Cut button to cut (delete) the 

contents of the Country field.  

 

The Country field should end up blank. 

4. Click in the Address 1 field. On the Edit menu, select Paste or on the Tool Bar, click the 

Paste button to paste (insert) the text that was cut from the Country field into the 

Address 1 field.  

5. In the Address 2 field, paste the contents of the Country field into that field as well. 

 

Now we have some changes with which to work. 

 

First, note that the fields that have been changed are in a different color than the fields 

that have not been changed. This makes it easy to see what you have done.  

6. Click in the blank Country field. 

 

Note that the Undo button on the Tool Bar becomes enabled. (If you position to an 

unchanged field, the button will be disabled.) Any field that has been changed, as 

indicated by the modified color, can be undone. Let’s try a few. 

7. Click the Undo button. 

 

The Country field, which was modified (by having been deleted with the Cut feature), is 

restored. The color is reset to the unmodified state and the Undo button is disabled 

because there is now nothing to undo in this field.  

8. Before you undo any other fields, select the the Edit History option on the Audit menu 

to display the Edit History log.  

 

Note that all of the changes you have made, except for the Country change that was 

undone, are listed in the order you made them.  

9. Now close the Edit History screen and undo all of the other fields one after another. 

When there are no fields in the modified color, you are finished. Now view the Edit 

History log again. There should be no remaining changes because all of them have been 

undone. 
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The undo feature supports multiple undos for the same field.  

10. To show how this works, change the Country field four or five times. Use whatever 

technique you want. View the Edit History log to verify that all of the changes to the 

field have been recorded. The Old Value and New Value columns should indicate the 

progress you made. 

11. Now use the Undo button to undo the last change you made.  

 

Note that the color does not revert back to the unmodified state and that the Undo button 

remains enabled.  

12. Now, undo each of the changes until you have restored the Country field to the original 

phrase.  

 

Now the color has been restored and the Undo button is disabled. 

13. Continue with the next tutorial. 
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Tutorial 3.4 – Undo All Changes 

The last tutorial showed you how to undo fields one at a time. If you make a lot of mistakes 

or if you inadvertently delete rows in a grid, you can undo all of the changes made during the 

current session. The technique is quite simple. 

1. Use whatever method you want to change four or five fields on the current screen. When 

the changes are complete, use the navigation skills learned in the last lesson to move to 

any other screen (Status, Compensation, etc.). 

2. Make a couple changes on that screen. 

3. Now return to the Personal screen. 

 

Note that the fields you had changed are still in the modified color and that they are still 

listed in the Edit History log. These changes have been captured, but they are not yet 

saved. Thus, they can be undone.  

4. Try the Undo on one of the fields you have changed. 

 

The Undo capability persists until you leave the current record. We have already seen 

how changes that are visible in the Edit History log can be undone using the Undo Field 

feature one field at a time. Now, let’s learn how to undo all of the changes you just made.  

5. On the Edit menu, select Undo All.  

 

The following message is displayed: 

Undo all changes made in this session? 

6. Click Yes. 

 

All of the changes made since the last save are undone. 

 

Note: A change made to the ID field in a record is immediately saved upon entry, so it 

won’t be undone. 

7. Go to the other screen where you made changes. 

 

You will see that those changes are undone as well. 

 

Undo All is particularly useful on grids. At the current time, there is no way to undo a 

row delete. If you inadvertently delete a row when you meant to insert a row, the best 

way to recover is to use Undo All.  

8. To see how the Undo All feature works on grids, select the Performance Appraisals 

screen. Delete a few rows and then insert a few other blank rows. When you have the grid 

completely ruined, use the Undo All feature and see what happens.  

 

The grid is restored to its original state.  

9. Return to the Personal screen and stay in Donald’s record. 

10. Continue with the next tutorial. 
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This lesson covers data entry in three different field types, which also have unique popup 

features. 

Tutorials 
Data Entry in a Table Supported Field: shows how data entry is performed on fields 

supported by both simple and complex tables. 

Using the Date Popup: demonstrates the date popup feature, which can be used to select a 

date during data entry in a date field. 

Data Entry in a Multi-Line Field: shows how the ENTER key moves from field to field. 

Then covers how to use the Multi-Line popup to do data entry in a multi-line field that 

requires the use of the ENTER key within the field. 
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Tutorial 4.1 – Data Entry in a Table Supported Field 

People-Trak utilizes optional table files. This means that many of the standard entries can be 

pulled from pre-defined tables. The advantage of using tables is that data entry can be 

standardized. When used correctly, you can avoid having a different version of an entry for 

every employee entered.  

1. You should still be on the Personal screen of Donald Stern’s record.  

 

To avoid the tremendous distraction of popup buttons all over the screen, People-Trak 

only displays the popup button when the cursor is actually positioned in a field supported 

by a popup.  

2. Press the TAB or ENTER key to move through each of the fields on the Personal 

screen.  

 

Note that both table and date popups appear in many places. If you see a popup button of 

some type, the field is supported by a popup. 

3. Click in the City field. 

 

The City field is supported by the City table. The City table is normally a list of those 

cities in the general vicinity of your facility. The simplest way to complete a field 

supported by a table is to use the popup feature. Try it now. 

4. Click on the button adjacent to the City field and select an entry from the table.  

 

Note that when the entry is returned from the table, the color is changed and you are 

taken to the next field.  

5. Click in the City field. 

 

Note that the Undo button is enabled. Selecting an entry from a table is just like keying, 

only faster. 

 

If you are accustomed to keying rapidly and do not like to leave the keyboard to use the 

mouse, any popup can be activated using the F3 key. Try it now.  

6. In the City field, press F3. 

 

The popup will be displayed just as if you clicked on the button. 

7. Click Cancel to not make a selection. 

 

You are not limited to using the popup on tables and certain other popup supported fields. 

You can key the value directly and validation against the table will be performed. Let’s 

try this. 

8. In the City field, enter Vista and press ENTER.  

 

The value is validated against the entries in the table and is accepted. Now let's try 

something else.  

9. In the City field, enter XXX and press ENTER.  

 



Field Types and Popups 

 

 Introduction to People-Trak     69 
 

This is a bogus city, and one of the two messages shown below will be displayed when 

entering a value that is not in the table: 

Entry is not in the table, Override Table? Yes/No 
 
or 

 
Entry is not in the table  

The first message is displayed when the usage of the table has been defined as optional. 

When a table is optional, entries are validated against the table, but you have the option 

of entering a value that is not in the table. The second message is displayed when the 

usage of the table is mandatory. When a table is mandatory, the entry must match an 

entry in the table or the entry will be disallowed. 

 

The City table is currently defined as optional, so you will see the first message. 

10. Click YES or press ENTER to continue.  

 

The value will be accepted or rejected according to the validation rules for the table. A 

table such as the City table is normally set to optional because there are many city 

possibilities. Other tables such as departments or job codes would be set to mandatory 

because these tables would never be overridden. 

 

Here is one more method of entering data into a field supported by a table.  

 

Note: In the examples below, the letters being entered are always shown in capital letters. 

The entry itself does not have to be capitalized to work. Upper and lower case letters both 

work. 

11. In the City field, enter S and press ENTER. 

 

All of the cities that start with “S” are displayed. If there weren’t any cities that started 

with “S”, People-Trak would have treated this entry like the “XXX” entry earlier, based 

on the usage defined for the table. 

12. Select San Diego. 

 

You could have also gone directly to the “S” entries in the full table listing as well.  

13. In the City field, clear the field and then click the popup button or press F3. 

 

The City table is displayed. 

14. Press S and you will be taken to the first entry in the table that starts with S. 

15. Press C and you will be taken to the first entry in the table that starts with C. 

 

You need to wait about two seconds between pressing the S and the C for the system to 

recognize that you are not trying to type multiple letters. 

16. Press the letters SAN in quick succession and you will be taken to the first entry in the 

table that starts with San. Press ENTER to accept that entry, which happens to be sunny 

San Diego. 
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Our City table is not that big, but on tables that have many entries, this “search” feature 

in a table popup can be very helpful. This search feature is also available in the Select 

Field and Select Document popups as well. 

 

There are dozens of tables just like the City table throughout People-Trak. The operating 

conventions are always the same. 

 

Tables (and all popups) work on grid text boxes just like they do on regular text boxes. 

Let’s try one. 

17. Click the Education button on the right side of the screen.  

 

The Education screen is displayed with the cursor in the Degree column of the first row 

of the grid. 

 

This field is supported by the Degree table. Note that the table popup button appears 

adjacent to the field for the current row only.  

18. Click the popup button or press the F3 key and select from the table. 

 

Because a table field is a table field is a table field, you can also key the field directly. 

The entry will be validated just as it was with the City field.  

 

The City table and the Degree table are simple tables and support the entry of a single 

field. There are other more complex tables that support the entry of multiple fields, if 

table mapping is being used. Let’s see how one of these works. 

19. Close the Education screen and don’t save your changes. 

20. Select the Training/ Competency screen. In the training grid, click in the Course Code 

field in the first row. Click the Details:1 button to display the course details for the first 

row. Close the subscreen. 

21. In the Course Code field, click the popup button to display the Select Training Course 

table. Select a course that is different from the current one.    

 

Multiple fields from the table are returned and added to the current record. Some are 

displayed on the training grid. Others are placed on the Course Details screen.   

22. Check this by clicking the Details:1 button. When finished, close the subscreen. 

 

When the table selection was made, the color of all returned fields is changed and an 

entry is placed into the Edit History log for each field. As far as People-Trak is 

concerned, all of the data entry performed from this table selection might just as well 

have been performed manually, field by field. Also note that the returned fields are 

display only because fields returned from table maps cannot be modified. Those values 

are determined by the corresponding table entry.  

 

Note: If you determine that there are some fields that you do not want returned from a 

table map, you can update the map and display only settings with utilities. If your 

organization elects not to use one or more of the tables, the key field works like any other 

field. It can accept any value that the length of the field allows. No special editing is 

performed, nor are any of the related fields displayed. 

23. Continue with the next tutorial. 
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Tutorial 4.2 – Using the Date Popup 

Date fields are notoriously difficult to enter. Fortunately, People-Trak has features that make 

date entry easier. As you saw in an earlier lesson, dashes were automatically inserted into 

dates as you keyed the digits to assist in the data entry and formatting process. People-Trak 

also provides a date popup feature at all date fields to allow you to select dates graphically 

with the mouse. Let’s see how to use it. 

1. Select the Personal screen. Click in the Birth Date field. 

 

Note that the date popup is displayed adjacent to the field. This same popup is displayed 

whenever the cursor is positioned to a date field on both regular text boxes and on grids. 

 

As with all popups, you can activate the popup by clicking the button or by pressing the 

F3 key.  

2. Press F3 this time to activate the popup. 

 

When the date popup is displayed, the settings for the month, day, and year are initialized 

according to the contents of the date field from which the popup was selected. If the date 

field contains a date, the values are initialized for that date. If the date field is blank, the 

values are initialized for today’s date. Check this now.  

3. Close the date popup and manually change the Birth Date to a birth date you know, 

perhaps your own. Then, activate the popup and note the month, day, and year reflect that 

date. Close the date popup. Now clear the Birth Date field. Activate the popup and note 

the month, day, and year reflect today’s date. Click the OK button. 

 

Today’s date is returned to the Birth Date field. The date popup is easy to use and is self-

explanatory. However, there are few tips that might help you. Let’s look at a few. 

 

Often when keying dates, you wish to set the date forward one year or one month. The 

fastest way to achieve this is to trust the fact that the date popup is initialized according to 

the contents of the date field from which the popup was selected. Now let’s assume that 

you wish to set the date one year forward… quickly. What would you do? The fastest 

way to advance a given date one year requires three clicks of the mouse. Let’s 

demonstrate this.  

4. In the Birth Date field, click the date popup button. Click the right arrow button adjacent 

to the Year dropdown. Click the OK button to close the date popup and return the value 

to the Birth Date field.  

 

You do not even need to look at the month or day values. Just click, click, and click.  

 

The same technique can be used for advancing a given date one month.  

5. In the Birth Date field, click the date popup button. Click the right arrow button adjacent 

to the Month dropdown. Click the OK button. 

 

Easy! 

 

Another way to get a date entered is using the Date Stamp feature. Whenever you start 

People-Trak the date stamp is set to today’s date. You then have the ability using the Set 

Date Stamp option to set the date stamp to another date. When you are in a date field, you 
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can use that date stamp to enter the appropriate date. You will learn more about the Date 

Stamp feature in the Data Entry training. 

 

You have now learned that you can “enter” data by typing in the data (remembering to 

clear any existing data first) or using the popup (when available) to select the data. So, 

when you see the phrase “enter” in training, it is your choice as to what method you use. 

6. Continue with the next tutorial. 
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Tutorial 4.3 – Data Entry in a Multi-Line Field 

There are times when a field must contain more text that can fit on a single line. This applies 

to comment fields, notes, short descriptions, etc. Rather than have the field scroll to the right 

indefinitely and be impossible to read, People-Trak provides larger field areas with which to 

work. These are known as multi-line text fields.  

 

Multi-line text fields present a dilemma in that you sometimes wish to format the field by 

using the ENTER key to create a new line. This is certainly acceptable, but normal operating 

conventions use the ENTER key to move to the next field. Thus, each time you might press 

the ENTER key at a multi-line field, the cursor would jump to the next field and you would 

get very frustrated. 

If the ENTER key was trapped and used to insert a new line directly in the field, the 

following, equally-frustrating scenario would result. When you press the ENTER key five or 

six times to position to a field lower on the screen and you pass through a multi-line text 

field, the ENTER keys would be used to insert rows in the multi-line field. You would grow 

very frustrated deleting the line and then having to remember not to use ENTER on that 

screen to move the cursor rapidly. 

Fortunately, People-Trak has provided a popup for multi-line text fields. Here’s how it works. 

1. Select the Wellness button to display the Medical/Wellness sub screen.  

 

Note that there are multi-line text fields on the screen. These are easily identified by the 

height of the field. 

2. Press the ENTER key a number of times to move the cursor all the way around the 

screen.  

 

Note that the ENTER key passes through the multi-line text field just like other text 

fields. 

3. Now click in the Restrictions field. Start typing a sentence and then press the ENTER 

key as if you wish to create a new line.  

 

Oops, the cursor just jumped to the next field. Now you have to position back to the field 

and try again, but the results will be the same. 

4. Click back in the Restrictions field. This time, click the multi-line popup button. A new 

text box appears. Now type your sentence and add lines and use the ENTER key as you 

please. Format the text the way you want. Now, click OK to close the popup and return 

the text to the underlying field. 

 

The text you have keyed should be echoed just as you keyed it in the popup.  

5. Now, press the ENTER key a bunch of times again. As with the last time, the ENTER 

keys will not be trapped by the multi-line text box and will not mess up your entry. 

6. Click back in the Restrictions field, and click the popup button again. 

 

If you type more text than can be shown in the multi-line popup screen, the scroll bar will 

activate to allow you to keep typing away.  
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7. Keep pressing ENTER until you reach the bottom of the text area. Pressing ENTER one 

more time will activate the scroll bar. 

8. Click OK to close the popup. 

9. Close Donald’s record, without saving.  

10. Continue with the next tutorial. 
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This lesson gives you a tour of all of the online help available with People-Trak.  

Tutorials 
Field Help: shows how to access field help. 

Screen Help: demonstrates how to access screen help. 

Help Topics: shows how to view the contents of the entire People-Trak documentation suite. 

Support Online: tours People-Trak’s online support website. 
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Tutorial 5.1 – Field Help 

Field help is available at any field. Let’s look at a field on the Enterprise Setup screen to see 

how this works. 

1. On the Setup menu, select Enterprise Setup. 

The Enterprise Setup screen is displayed. 

2. In the Enterprise Name field, press F1. 

The Field Name: Enterprise Name screen is displayed. 

On the top left hand side of the screen, you will see a pane where Overview is 

highlighted. In the viewing area of the screen note that there is an overview of the 

Enterprise Name field. 

In addition to an overview, field help provides information about the properties and 

attributes associated with the field as well as where the field is used. 

3. Close the Field Name: Enterprise Name screen by selecting the Close or X button. 

 

Now for another way to look at field help. 

4. On the Tool Bar, click the Show Field Help button. 

 

Once again the same help screen is displayed. 

5. Close the Field Name: Enterprise Name screen. 

6. Click in any other field on the Enterprise Setup screen and use one of the two methods 

to pull up field help for that field. 

 

Field help is displayed, except this time the information is for the field you chose. 

7. Continue with the next tutorial. 
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Tutorial 5.2 – Screen Help 

Screen help is available at any screen. Since we  are already in Enterprise Setup, let’s look at 

the screen help. 

1. You should still be on the Enterprise Setup screen. 

2. Press SHIFT + F1. (Hold down the SHIFT key while pressing the F1 key.) 

 

The Screen Name: Enterprise Setup screen is displayed.  

On the top left hand side of the screen, you will see a pane where Overview is 

highlighted.  

3. Click the “+” sign adjacent to Overview to expand the tree. 

An overview of the Enterprise Setup screen includes help articles about the screen itself, 

enterprise setup terminology, and an introduction to the concept of enterprise setup.  

Let’s take a look at the Enterprise Setup Screen help. 

4. Select Enterprise Setup Screen so that it is highlighted. 

The help text is displayed in the viewing area once the topic is selected. Read and scroll 

down and soak up the knowledge! 

5. Click the “+” sign adjacent to Screen Objects. 

The tree view expands to show the different tabs found on the Enterprise Setup screen. 

6. Click the “+” sign adjacent to Settings Tab 

The tree view expands to show the  frames found on the  Settings tab. 

7. Click the “+” sign adjacent to General Settings Frame 

The tree view expands  to show the fields found within the General Settings frame. 

8. Select the Email Server Address field 

In the viewing area of the screen, we can read the help text for the Email Server Address 

field. 

9. Close the Screen Name: Desktop Setup by selecting the Close or X button. 

 

There is one more way of accessing screen help.  

10. On the Tool Bar, click the Show Screen Help button. 

Once again, the Screen Name: Enterprise Setup screen is displayed.  

11. Close the Screen Name: Enterprise Setup screen. 

12.  Close the Enterprise Setup screen. 

13. Continue with the next tutorial.  
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Tutorial 5.3 – Help Topics 

Help topics are available on any screen by using the Help Topics option on the Help menu. 

The Help Topics option allows you to view the contents of the entire People-Trak 

documentation suite.  

First, let’s look at how to pull up help topics from a screen. You should still be in the 

Personal screen. 

1. On the Help menu, select Help Topics. 

The Help Viewer screen opens up with the Contents tab displayed. When selected, 

Contents tab shows a preloaded list of reference documents with the first document 

highlighted. Documents are displayed in a three level tree view organized first by 

document, chapters, and sections in each chapter. Let’s take a glance at the 

Administration guide using this tab. 

2. Click the “+” sign adjacent to the Administration guide. 

As you can see, the tree has expanded to show the  chapter headings for the 

Administration document. Notice that these same headings are also displayed in the area 

to the right. Now that we can see the chapters that this document contains, let’s take a 

closer look at one of them. 

3. Click the “+” sign adjacent to the Enterprise Setup. 

This time, the tree has expanded to show the section headings for the Enterprise Setup 

chapter. The display area now shows our selected chapter and the section headings as 

well. 

4. Click the Introduction to Enterprise Setup section. 

The Introduction to Enterprise Setup article is displayed for you to read. Help articles are 

just clicks away! 

But say we forgot how to copy a table, and that’s all we really want to read about. We 

don’t have time to browse through different guides and chapters.This is a situation where 

we can utilize the Index tab. 

5. Select the Index tab. 

Under the Index tab, contexts are listed alphabetically. Help articles can be viewed for a 

particular context by simply selecting it. 

6. Scroll down through the list of contexts and select Copying Tables. 

The article is displayed in the right hand area of the screen for us to read and brush up on 

your table copying skills. 

7. Select Close to close the Help Topics screen and return to the Organizer Desktop. 

8. Select the Setup menu and look at the list of menu options.  

Module Setup has caught our eye and we want to learn more about it, but we don’t know 

where to start. This is where the Search tab comes in handy. 
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9. Close the Setup menu. 

10. On the Help menu, select Help Topics. 

11. Select the Search tab. 

The Search tab article results are blank when the Help Viewer is first opened. In order to 

search articles, all you have to do is enter the desired phrase or text in the search box and 

select the Go button. All articles containing the phrase in the heading or article contents 

will be returned to the Search pane in list format.  

We want to search for all articles that contain the phrase Module Setup. 

12. Enter the search phrase Module Setup and select the Go button. 

Immediately, the applicable articles are listed. The first article is highlighted and ready to 

read. Select another article in the list that you would like to read. 

13. Select Close to close the Help Topics screen and return to the Organizer desktop. 

That’s a quick tour of the Help Topics feature of People-Trak. All of the documentation 

available with People-Trak is at your fingertips. Be sure to use this wealth of information. 

14. Continue with the next tutorial. 
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Tutorial 5.4 – Support Online 

Online support is available on any screen by using the Support Online option on the Help 

menu. This option allows you to connect to the People-Trak customer support website.  

 

Let’s see what’s available! 

1. On the Help menu, select Support Online. 

 

Your browser opens and, as long as you are connected to the Internet, you are connected 

to the www.people-trak.com website and directed to Log In to Your People-Trak 

Account page. 

Once logged in, a user can view and update the account and company information, 

explore resources, view purchase history, submit support requests, and much more. Since 

User Names and Passwords are unique to the user, we won’t be logging in for support at 

this time, so let’s return to People-Trak. 

2. If you are taking this class via WebEx, close the People-Trak tab on your web browser 

(leaving your WebEx tab still open) and press ALT + TAB to return to People-Trak.  

If you are not taking this class via WebEx, close your web browser, and you will be 

returned to People-Trak. 

There is one more Help menu option that we will take a quick peek at before we wrap up 

this lesson.  

3. On the Help menu, select Help About. 

The Help About screen is displayed with information about our current training 

implementation of People-Trak including installation date, version, version date, number 

of records licensed, support expiration date, data file path and log file path. Other product 

options are also listed and their associated check boxes are displayed as selected when 

they have been licensed. In our case, we selected the Position Control and Attendance 

options for our training session, so you will see those options selected here also. 

 

The Help About screen will provide you with key information about your People-Trak 

implementation when you access it from your own system. Your Support Representative 

may ask you to reference this screen as needed. 

4. Close the Help About screen. 

5. Exit People-Trak. 

6. This concludes this tutorial and lesson 
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